Samsung Watch 4

Hey @petr-urbandroid, two things:

  1. I’m getting my GW4C today and I’m a JS programmer - can I help in any way with the SpO2 issue?
  2. Maybe the authors of the mod linked below could shed some light or share helpful resources?
    https://www.xda-developers.com/enable-ecg-blood-pressure-galaxy-watch-4-with-non-samsung-phones/amp/
1 Like

Hello,

I was wondering if we could monitor sleep data without Bluetooth connection to the phone.

Like let the watch SaA app do the logging and sync it in the morning.

That would save battery i guess.

Also any update about the spO2 sensor? as samsung released a “major” update a few days ago.

Ahoj @petr-urbandroid!

I’ve just upgraded my watch from Galaxy Watch Active 2 (Tizen OS) to Watch 4 and discovered the vibration pattern is different (as you mentioned above) and takes some getting used to. (The vibrations started immediately on GWA 2, but on GW 4, the vibrations take tens of seconds to build up, so it’s needed to delay the alarm sound. Otherwise, the sound wakes me up earlier than the vibrations. :frowning_face:)

Could you consider adding an option to set a custom pattern or at least a similar one to the pattern from GWA 2 (or default alarm pattern which is used by Samsung clock application), please?

I’ve been a happy customer enjoying all the possible modifications, especially captchas, over the past ten years, but this is the first time I have considered using the default clock app from Samsung.

Thank you!

@Hardy sorry about that, we have many implementations on many different wearable platforms and those can slightly differ in behavior.

In general the idea is to use gentle vibrations which find the minimal intervention needed to wake you up to make the experience more pleasant…

At the moment we start with a short single vibe at alarm start with a 30s delay - another vibe 20s - another till this becomes constant vibration.

If for your ringtone sound is faster that vibe for waking you up there is a simple fix, just put a e.g. 1 minute delayed sound start on the alarm…

We will look into this and see if we can fine tune the pattern for a better experience in your case but as always if you do such changes you can expect a lot of negative feedback from users used to this pattern who will find the Tizen platform vibration too strong…

1 Like

I cant get the alarm to go off on my watch. GW4. I have the beta version installed. I am unsure what companion apps I need to have installed. There is a galaxy gear add on and sleep as android unlock app. I had both these and it didnt work. Then i uninstalled both and it still doesnt work. Any help is appreciated.

Thanks

I got it to finally alarm after updating the beta version to my phone. The snooze screen does not come up automatically and I have to select the bottom of the watch to get the snooze screen. Is there a fix to this? I also am not a fan of the slow starting vibration. Having changeable options would be best. Thanks

@petr-urbandroid

Might be a silly question but have you looked at getting the sp02 data from Google Health Services on the Watch 4?

@Haffoc many thanks, in fact we plan this, although health services are getting more and more strict and for instance Google Fit does not more allow to read any data without an expensive auditing process… so I expect Samsung will follow soon so honestly it is a question whether this still makes some sense. Also I do not think we will get the detailed data - SPO2 every second which we need to calculate any Respiratory Disturbance which is why we are doing this…

Ever since the latest GW4 watch update last week, I only get a couple hours of tracking data and then the HR and movement graphs go flat.

Any ideas why?

2 Likes

Same story here, and the alarm is no longer working.

Given that I have also had the always on display for custom watch faces stop updating, I’m guessing that Samsung has started Doing Something to apps running while the screen is off.

Hopefully soon either Samsung will fix it, or a workaround can be found.

I had the same problem. Solution is very simple: Galaxy Wearable -> Apps -> Sleep tracking -> Allow background activity

I hope it helps :slight_smile:

1 Like

I’ll try that. I also found it doesn’t happen if I’ve unlocked the watch right before bed. I suspect the watch getting locked stops it sending the data to the app. Hopefully the background setting will resolve that.

Made an account just so I could say thank you! :grinning: Tried it out last night and it appears to have fixed the problem. Also made that same change for Watchmaker and it seems to be a fix for the “3rd party watchface not updating” bug too.

Same here… trying today the fix and get back with results.

Thanks in advance!

Works here also!!!

Thanks…

Hello, sorry for not posting here as well, the solution is discussed on this thread Galaxy Watch 4 heart rate not tracking since newest update

1 Like

I just got a Watch 4 Classic, and I haven’t been able to get it to consistently share heart rate or o2 with SAA. If I check SHealth, I can see that both were tracked all night, but my SAA data shows heart rate was only recorded for part of the night, and o2 was not recorded at all.

Any ideas what I can check? I’ve already made sure that sleep tracking was allowed to run in the background.

Hello @Lisa_Clarke, in the screenshot I see that Sonar was also used for this session, so my theory is:

Something happened short after 12:00 - mayeb the phone rebooted, maybe your phone did kill the app (see https://dontkillmyapp.com/ ), maybe the new battery optimization algorithm stopped the app on the watch, we were abel to recover the sleep tracking process, but did not manage to connect to the watch anymore and fallen back to Sonar. The phone was probably not positioned properly to do a proper Sonar tracking so this is why you see mostly no light sleep after that time…

Can you please check https://dontkillmyapp.com/ for any non-standard battery optimization on yoru device?

Can you please check the Galaxy Waar app on yoru phone… look for Sleep as Android and allow “Background processing”? This is discussed on the Galaxy Watch 4 thread linked from this thread.

Also please consider using menu > report a bug to give us more details on the issue…

Thank you for replying. I had already checked all of those background battery settings. I’m not sure what happened, but everything was fine tonight, so I guess I can chalk it up to being a fluke.