Galaxy Watch 4 heart rate not tracking since newest update

Hi everyone,

I just found out that the heartrate sensor of the Galaxy Watch 4 doenst work with sleep as android anymore, since I installed the new update, which came out 2 days ago (Version nr: R875FXXU1EVA8).

Are you already aware of this problem?

Thanks

Hello @spqx … I tried a short track with GW4 yesterday as I saw a system update arrived… my aim was to check if finally Samsung did open up the SPO2 sensor so that we can use it… unfortunately they still require a permission only Samsung apps can own… anyway during this period I was receiving heart rate… I will try a longer track…

For me, sleep tracking stopped after about 1,5 hours and in the morning, the watch did not vibrate.
I’m also on the new Watch 4 update.
I just allowed background activity for the sleep tracking app on the watch. Let’s see tomorrow, if this fixes the problem.

Hi everyone,

I can confirm the red bars of doom are back :sweat_smile:
I also suspect some kind of battery optimization, as it seems to start happening after a couple of hours of sleep.
Will look into the background activity settings. Didn’t even recall there were such settings on the watch.

Here the last 2 nights of sleep:

1 Like

Good morning! :wink:
Allowing background activity seems to solve the problems. Sleep tracking, heart rate and vibration work again.


You can find it in the Wear App on the phone -> settings -> apps -> sleep tracking

Have a nice weekend!

5 Likes

@nommy wow, many thanks for sharing this, I’m wondering what is Samsung doing :frowning:

@nommy could you maybe share a Screenshot where to find the “allow background activity”? The only Things I can click are open deinstall or stop at the bottom.

For me, it looks like this:


Maybe you have to update your Galaxy Wearable App (I’m on Version 2.2.47.21166061).

Hello, I can confirm the issue and the “Allow background activity” workaround on my GW4, big thanks again for sharing the workaround as this option really isn’t easy to find…

Here are some more screenshots for where to find the option…

1 Like

We are also preparing a hint about this in the Wearable selection screen for the next release…

3 Likes

@nommy and @petr-urbandroid thanks for the Screenshots. Unfortunatally I am on the latest Version I can get from the play store and galaxy store which is 2.2.47.211220611 from the 10th of february. I use a galaxy s20+. Maybe I have to weit a bit longer

I’m using a Galaxy S10. Are you on Android 12 or still on Android 11. (My S10 is already on 12).

Oh ok, thats interesting. Yes I am on Android 12. Last Update was on the 3rd of february.

Just checked the settings again and for whatever Reisen the Option is now available :grin:
Thanks for your help

Unfortunately, on both the S21 Ultra and S22 Ultra, even setting the app to “unrestricted” (same as allow background activity) doesn’t solve this for me. I’m using the beta version of the app.

it tracked for ~1.5 hours before stopping and showing only the red bar.

I’ll try again tonight, just as a sanity check to be 100% sure (I’m on my new S22 that just arrived, and I am pretty certain I set to unrestricted last night, and not this morning, but I’ll try again tonight just to be sure).

1 Like

Here’s what it looks like on a galaxy phone just to confirm since it’s slightly different!

Sadly, I tested again last night, with the setting as it is in the screenshot above, and tracking stopped after an hour or so.

Why should you have other options? I think your are searching on the wrong end. Is this the setup of the Android app.

The option requested here is for the app on the watch (you have to setup on the phone). Go to your Wear App on the phone and go to “Watch setup”. There you may find apps–>sleep tracking too. This may match the screenshots above.

ahhh, I misunderstood and thought it was for the phone app because the screenshot looked a lot like the phone app settings screen - thanks for the clarification. Looks like my own mistake! Just enabled background activity on the watch app, and will test again tonight! Thanks for clarifying.

I got my GW4 a week ago, paired with an S21. Everything is updated to latest versions, and I cannot allow background activity - the option is greyed out. I can’t change it for any apps through Galaxy Wear -> Watch settings -> Apps :frowning:

Anyone got any ideas?

GW4 version: R870OXM1FVC8
S21 version: G991BXXU4CVD2

UPDATE:
I decided to reset the GW4 and start over.
After reset, I installed SaA on the watch FROM the watch Play Store, closed Play Store and went to my phones Wearable app Galaxy Wear -> Watch settings -> Apps -> Sleep tracking and finally the option to enable background activity was available.