Smart Wake Up feature not working

Detailed description of the problem:
The “smart wake up” is at the default time, 30 minutes, but I have a different alarm for every day of the week. I have configured the smart wake up to be at 25-30 minutes on most days, but on sundays it’s 1 hour and fridays it’s 5 minutes.

I read through the docs and tried to both lower and higher the sensitivity, but no matter what I do, the smart wake up feature will not work. The alarm only ever goes off at the set alarm time .

So if I have a smart period between 8.00 - 8.30, it won’t ever wake me up before 8.30. Today I woke up at 8.10 (within my smart wake up period) and Sleep As Android detects me as awake, I am even using my phone, and the alarm will not go off.

Steps to reproduce:
I don’t know.

Version of Sleep as Android:
The latest version.

Hello, do you use Not before ideal feature? How long was your last tracking? Was the sleep duration goal met when the smart period started?

Hello (I will respond here too instead of my bug report on email)
It currently says I slept for 9 hours, between 22:58 - 8:17 (22:58 is when I started charging my phone for the night)

I have changed sleep tracking now from “Smart period” to “After fall asleep”

My minimum sleep duration is set to 8 hours, but since the app thinks I slept from 22:58 to 8:17 it should have went off anyway right?

Thanks for your help

Edit: I turned off the “Not before ideal” feature now, it was indeed on. Hopefully it will work tomorrow.

Edit2, uploading a picture from this morning

The tracking duration at that point is only 1 hour and a few minutes, so the sleep goal was not met. The Smart period tracking start method will only start the tracking for calibrating the sensors for smart alarm. It does not cover the whole sleep.

The rest of the duration was saved as an individual entry with Sleep time estimation.

Let me know tomorrow, how it went. If there are still some issues, ideally send the logs again.

Well my update is here… I changed the automatic sleep tracking from “Smart period” to “After fall asleep”, my phone does support Sonar so… but it never started tracking. And my alarm went off at the set time (like usual).

I tried reading the docs etc for what to do when “After fall asleep” doesn’t work, but I didn’t find anything about that. I sent logs again from my gmail. Thank you

If the tracking does not start automatically, it could be some awake-like event postponing the start, a condition about charging configured, but not met, or some “optimization”.
I could not find the logs - could you please send them again?

I tried sending it again, yes that is turned on but I always charge my phone during sleep, next to the bed. Logs should be sent now

OK, got the logs - you have a Phaser configured as your main movement sensor, but it was not connected when the app tried to start the tracking. Do you have a Phaser? Which type?

I do not have a Phaser, I’m trying to find where I can disable this.
In “Sleep Tracking” I have this:
Sensor: Sonar
Wearables: None
Pair Tracking: Off (used to be on for some reason)

But I’m not finding the phaser option

Settings > Services > Smart light:


Thanks! I turned that off and waited until this morning, but sleep tracking never started once again. I will send my logs again. Today Sleep As Android estimated my sleep time but sleep tracking actually never turned on

Hi, I replied via the support too.
From the logs, there is a constant “using the phone” activity reported from the system each time Sleep is trying to start the tracking.
Can you think of a reason, why would your system insist on this? It was happening till the morning.
Is the device in a tilted position? Or is the charger wireless?

Hello, I read that but I can answer here.
Yes I fell asleep at around 1:45 so I rescheduled the alarm before that. After that there should be no activity really. I usually sleep with an open window with a city street outside so I have been thinking that might cause some disturbance, but I am not sure. I mean the sleep tracking doesn’t even seem to start no matter what I do.

The sleep estimate is quite correct, though.
I don’t know why the system would think I was using the phone.
I am using a wired fast charger, my phone is on the bed table like 40 cm away.

Is there any option to force start sleep tracking after a certain set time? Or like, start sleep tracking 15 minutes before bed time or something, or send sleep tracking requests before bedtime… That should solve it, maybe. I don’t know. I mean the sleep time estimate was mostly correct, but it still thinks I actively used my device all night?

I don’t think my phone was in a tilted position, but it is possible - but my phone screen was definetly off and phone locked all night

Thanks again for all your help

The tracking was not postponed because of the environmental sound level, it was only phone’s activity reported by the system.
Would it happen with a normal charger as well?

The Bedtime start method will start always at the bedtime (so it depends on the alarm time and the configured daily ideal sleep income).

Okay. I gave “Sleep As Android” admin rights on my phone and unlimited background data usage just to make sure it wasn’t something killing it off.

I made sure the phone lay flat on my bed table and slept with windows closed just in case. My daily sleep income is set to 8hrs 10mins I think.

At this point I don’t know what to do to make this work. Should I upload pictures of all my settings? Or maybe you can already see them in the logs.

Hi, the issue is not with the background data or background restrictions - your app did run the whole time. But each time it tried to start the tracking, the system sent “phone is used”, which is considered as awake activity.
The settings are good, but is there a reason your system would think you are using the phone? Does it happen with a normal charger?

I really dont understand why the system thinks I am using my phone, to me its locked and screen is off.

I would say my charger is normal, like, its just a wired charger but slightly higher watt than usual maybe, its just supposed to charge my phone slightly faster. I could try with my other charging cable to see if the issue persists.

In our logs, we do not see, why the system thinks that. The charging is only a guess, as it is the most common reason. You are using the accelerometer, right? Would it be possible to try one night without charging (for example before a free day, so you won’t get limited by unfilled battery in the morning)? That would either confirm or refute this guess.
Without the constant “awake when using phone”, the app would probably have started the tracking, it really tried many times during the night.

I have been trying to use Sonar. I have done this in the past aswell with different phones to no luck, I don’t know why, but sleep tracking has never worked properly for me. I tried the Sonar in the settings and it tells me my phone is compatible.

I switched from “After fall asleep” to “smart period” this morning because I kinda gave up on it.
My other settings are:
Phone needs to be charging: Always
use Google API
Awake detection: Medium Sensitivity (Movement: High, Heart rate: Medium, Light: Medium, Sound: Medium, Awake when using Phone: High)
Sensor: Sonar (should I switch to Accelerometer?)
Wearables: None (everything has been turned off in this section)
Delayed sleep tracking: 5 minutes
Pair tracking: Disabled (I don’t sleep alone, but my partner does not have Sleep As Android app)

When I use “Test Sensor: Sonar” on frequency 18-22, it tells me: “Sonar is supported: 510 signal strength”

Screen Dimming: Dim
Do not disturb: on
Priority mode: on
Standby: When battery <20
Battery optimized: off

I could try without charging, but then Sonar won’t turn on, right? Or should I switch to accelerometer? I barely know the difference, but Sonar is what I thought to be the preferred option.

Sonar needs charging. So if you switch to sonar, we won’t be able to test, if the mysterious phone’s activity comes from the charging or not. Would it be possible to keep the accelerometer for one night?

Smart period tracking start only starts the tracking for calibrating the sensors. It will not track the whole night.
For the whole night, you need either After fall asleep (and no awake-like events), or Bedtime mode.

Sonar signal strength is not bad, but that does not mean the proper readings are ensured. What does the graph look like? If the sonar signal is weakened, the graphs are suspiciously flat, with a lot of deep sleep (because the app has trouble detecting the movements).