Sleep as Android keeps turning my alarm volume off


#1

Hi,

I have been struggling with this issue for a few years now, and I can’t seem to find what’s causing it. I’m pretty sure it’s Sleep as Android though. I’m convinced it’s just a setting that I just can’t find but I can’t seem to Google hard enough for information on this.

A lot of times I find myself waking up to a silent alarm that does nothing but a constant interval of brief vibrations. I’d check my alarm volume at that point and it would be turned all the way down.

I know I have an issue with ignoring my alarm, but it’s the very reason I have Sleep as Android, and I don’t want it to be adjusting the volume of my alarms at all. My environment is such:

Phone: OnePlus 5T (before it was my Nexus 6)
OS: Android 9 (Though it’s been this way since android 6 for me)
Sleep as Android version: 20190109

My alarm is set to all alarm default settings. And for the default settings, I’ll upload them here:

How can I get it so that Sleep as Android does not decrease my alarm volume ever?


#3

Hello, please send a menu - report a bug, I will see if we touch alarm volume anywhere… I would suggest you use Gentle volume increase = X minutes… this will make sure to increase your alarm volume so that alarm will always wake you up…