Large delay in Webhooks triggering ifttt service

Detailed description of the problem:

When I use Webhooks and “alarm_alert_dismiss” to trigger IFTTT to turn on my Sonos radio when I dismiss an alarm it should turn on the alarm immediately but the Ifttt recipe is not running until hours later. It triggered at 3am this morning while I was sleeping! Are there problems with Webhooks either with Sleep as Android or Webhooks & Ifttt?

Steps to reproduce:
See above

Version of Sleep as Android:
20200330

1 Like

Those delays are one of the reasons I’ve created this request - not to depend on webhooks to be sent timely

Hi, we’ve found the cause of the delays and why we haven’t been able to reproduce it (until now).

This issue occurs if you are using an old IFTTT key. IFTTT website will change your API key whenever you click on the Edit button on this page: https://ifttt.com/maker_webhooks/settings, but it does so pretty quietly so you may not even notice that.
If the key is changed, your old key (which is stored in Sleep as Android) will still work, IFTTT servers will respond to a request using the old key in the same way as with using the current key - but a significant delay will be now introduced between sending the request and performing the action.

So please, if you face this issue:

  1. Go to Sleep as Android > Settings > Services
  2. Toggle IFTTT off and on again (this will take you to the IFTTT settings screen)
  3. a. Either fill in your new key manually, or
    b. Login to IFTTT from there and then tap the RETRIEVE button.

From then on there should be no delay again.

1 Like

Woow, big thanks Jiri for finding this out!