Google blocking sleep as android

Detailed description of the problem:

Google services notification “sleep is having trouble with google play services” shows banner attached

Steps to reproduce:
Enable fit integration

Version of Sleep as Android:

same with 22578

20210112 22533 premium

Hello @Andrey_K

Google Fit did make a lot of restrictions on available scopes which are no more available without a verification process ad Google, we have spend the last half year going through that process and are able to at least wrote to Google Fit with the latest version.

We have had such glitches reported and some threads are on this forum as well, as so far what works for users is to remove the permission from the Google account and re-add it.

Did that work for you as well?

Hi, nope, didn’t work. I’ve removed all permissions, restarted the app, connected to Fit and hit “upload”. Got the same notification.

Just to double check we are on the same page…

You did go to your Google account settings > Data & security > Third party apps…

There you found Sleep as Android or SleepCloud - this depends if you are using also SleepCloud…

There you have tapped on remove access. Than you did try to uncheck Google Fit integration and check it again?

Hi Petr,

I’ve unchecked google fit, killed the app, removed access from google accounts page, restarted the app and enabled the integration.
When I tried to upload got the same notification.

@Andrey_K than I’m a bit clue less :(… asking Google for support would be like carrying water in sieve… Would you try to uncheck Settings > Privacy > Read sleep data and retry the steps?

Hi,

Didn’t help too. I guess I can live without feeding sleep data to google anyway :slight_smile:

Sorry for not being more of a help… we are looking into this

Thanks, please tag me if a solution will be found. Have a nice day!

@Andrey_K ok… we have checked past support conversations and in many cases the steps with remove account did fix the issue… we are just seeing two cases then this did not happen.

  1. we recommended to uncheck the GoogleFit: Read sleep data option but we did not get feedback if that helped
  2. For one user removing the account did not help, but after a BETA update arrived for him the issue was resolved - but the update IMHO is unrelated to the issue

Tried removing access again just in case, didn’t help.

For the record: OnePlus 8, Android 11, Oxygen OS 11.0.9.9.IN21BA.

Hello Andrey, which version of the Sleep app you have now installed (either long-press the Sleep icon > Info, or in the Left ☰ menu > (?) Support > Release notes)?

It’s in the first message in the thread

20210112 should be a version from January.
The version names are actually the code for date of first release YYYYMMDD, so in this case it would be January 12th this year.
Anyway, one user reported the message went away after the app updated to the BETA. Would you be willing to test it?
You can either follow https://docs.sleep.urbandroid.org/faqs/get_beta.html, or contact me at support@urbandroid.org.

I had the version number in my blind spot :)… as 20210112 is very similar to the quite recent version 20211112 but I guess this was just a typo?

Hello @Andrey_K are you really using version 20210112 ?

None of the above helped me.
I have 2 step verification enabled in my Google account, so I can’t turn on Less secure app access.
Google says:

This setting is not available for accounts with 2-Step Verification enabled. Such accounts require an application-specific password for less secure apps access.

Maybe if we were able to sign in to our Google accounts by using app passwords, then that might be a solution.

@Akos_Balogh I also use two step verification and I do not have this issue. We did not yet find out what is causing this rare issue, my theory is that this is because some now restricted scopes are still used in the authentication somehow because you used them before with an earlier version of the app or you are still using an earlier version…

What service is causing this issue? SleepCloud, Google Calendar or Google Fit?