Fitbit Ionic/Versa beta integration

I use a mi-band for tracking but i realy want my versa to be my sleeptracker.
I have the latest beta of sleep as android and the latest versa app (1.5)
In SaA i selected the fitbit als my device. (no notification showed up about fitbit server)

The devices aren’t connecting.
When i start my sensor test in SaA and then open the app on my versa, it stays on “connecting…” state forever. Rebooting both devices did not do the trick.

I am using a moto g5s plus with all latest updates installed

Any advice for getting this to work?


With my Ionic the last night the same problem. Before it was working, I’m not sure, what was problem last night.
I will check again and repost.

As replay for both @Doray and @Martin_Strell

if shutdown/start Ionic/Versa and restart cell phone does not work, try reinstall the watch companion app.
also check the watch and the Fitbit app are communicating fine, if the Fitbit app does not see the watch, SaA will not be able to see it.
Some times it takes me to force close SaA and Fitbit app for the watch to connect to SaA.

Hope it helps.

This night was working again very well.
I don’t know what was wrong.
You’re right. Sometimes I try and when it not works I close both apps and normally when I retry it works fine.
But the night before I tried a few times.
So was strange but I don’t mind.

Fitbit Ionic user here. Recently downloaded the app. I have been unable to get the app to connect with my fitbit. I have tried various things
3 different android devices
reset the watch
“Classic” bluetooth setting connection from watch
Watch shows “Connecting…” and when the app gets to the end of the 2 minutes it starts tracking without the watch.
Normal fitbit app sync seems to be working fine. All day sync and always connected are on.
Any other thoughts to try are appreciated.

My Pixel 3 XL updated to 10!
Now every night I need to restart the phone to be able to start the sleep tracking.
When I start the tracking it will not connect even if I restart the Ionic, the only way is restarting the cell.

Note: we have not have an update in a month. There are any new news?

@devonalysha did you try to restart both the watch and the cell? did you uninstall the companion app on the Fitbit and reinstalled it again?

@ludohavil, restarted and both watch as well as one of the 3 android devices have had a factory reset this week.

I’ve been using the integration with my Versa for about two months now and it worked good, only problem was connecting sometimes, but that was often fixed by syncing the Versa with the fitbit app.

I’ve now upgraded to a Versa 2, the app cannot be installed at the moment. Is there an eta when it will be available for the new Watch?

Thanks for the awesome work

Yesterday the long-waited upgrade arrived to Versa lite. And now my sensor checking app show values instead of none. Unfortunately I was not able to make it work last night, but today morning, after I rebooted the phone, the watch was able to connect. I’m looking forward to this evening to actually test it.

Thank you for your persistence. I will make the app available on Versa Lite again!

What about Versa 2?:hugs:

The SDK for Versa 2 still wasn’t released, so I can’t release the app for Versa 2 yet. It’s a little strange flow from the Fitbit team - they want to make sure that all of the devices have had chance to update to the new firmware and only then they will release the SDK 4.0 to the devs. This SDK includes the option to build apps for Versa 2.


With my Ionic there was some troubles to connect to sleep app the last few days.
I don’t know, what happens. Various updates in the last times, but I could not establish a connection.

I solved the problem, now it’s connecting again normally.
I will write the steps, so somebody with the same problem could may solve with this points.

  1. Disconnect the ionic from Bluetooth and reconnect via fitbit software
  2. Uninstalled the companion app on watch and reinstalled, also set the permissions
  3. Uninstalled and reinstall the ionic in fitbit app.

I hope some of this solutions will help.

Hi all,

Just want to say that I am blown away by the team at SaA. I discovered the Fitbit Versa app for it a couple of months ago and it’s the only way I sleep now. However, as of 11/3/2019, I can no longer get the companion app to connect to the Sleep as Android app on my phone no matter what I do. I have now enrolled in the beta for the app on Android to see if that helped but unfortunately not. I recently got the Versa update they pushed out, but I can confirm that the SaA companion app was working after that update. I have since repaired my Versa through the app to see if it would help and unfortunately it hasn’t. I tried changing the connectivity to automatic instead of specifying fitbit and that didn’t go either. Force closing apps, restarting phone/watch, etc haven’t made a difference.

I did notice that in the app store through fitbit the Companion app has a little “lock” symbol next to it, which doesn’t seem normal. Wonder if there’s something there?

Anyway, anything you guys can suggest to get this functionality back would be welcome! Thanks!

Edit: after reading the above reply about the 4.0 SDK, it could be that since the Versa 1 was updated to that version that you have no way of fixing the app for the Versa 1 now until they get you that SDK. :frowning:

1 Like

I’m having the same issue, I’ve tried rebooting both devices and reinstalling the apps on both devices and deleting the versa in Fitbit and re-adding, nothing works. Pretty frustrating. It only started last night for me and I hoped it was just a temporary thing but it’s still not connecting.

1 Like

Yeah, it is unfortunate because without the fitbit support I don’t exactly have as good of an experience with SaA. Since this issue occured, the app has been waking me up pretty much 30 minutes before my alarm (I have the smart alarm at 30 minutes) but I don’t sleep with the phone in the bed with me so I don’t think it’s working correctly.

Getting this fixed would be so appreciated. Let me know if I can be of any use to accomplish that!

Hey embw (and anyone else that has this issue),

I just tried something – I downgraded my Android App for fitbit to version 3.8 (released on Oct 21st) by uninstalling the app, downloading the APK from apkmirror and turning off “auto-update” for the app in the google play store. This fixed the issue for me. Seems like the Nov 4th version of the app broke notifications and connectivity to the fitbit in general. I tested and now SaA and the companion app are talking to each other again. :smile:

1 Like

Hi Andrew, thanks for the suggestion, I’ll give it a go but I don’t have high hopes considering I still have notification functionality. It’s worth a shot though, I’ll let you know how it goes.

1 Like

My Fitbit - SaA has been broken for a few days, nothing has helped, restarts, reinstall and so on.

After reading this I downgraded my Fitbit app to 3.8, and now it works.

I had no problems with Android Notifications, only Sleep.

1 Like