Fitbit Ionic/Versa beta integration

I’m having the same issue, I’ve tried rebooting both devices and reinstalling the apps on both devices and deleting the versa in Fitbit and re-adding, nothing works. Pretty frustrating. It only started last night for me and I hoped it was just a temporary thing but it’s still not connecting.

1 Like

Yeah, it is unfortunate because without the fitbit support I don’t exactly have as good of an experience with SaA. Since this issue occured, the app has been waking me up pretty much 30 minutes before my alarm (I have the smart alarm at 30 minutes) but I don’t sleep with the phone in the bed with me so I don’t think it’s working correctly.

Getting this fixed would be so appreciated. Let me know if I can be of any use to accomplish that!

Hey embw (and anyone else that has this issue),

I just tried something – I downgraded my Android App for fitbit to version 3.8 (released on Oct 21st) by uninstalling the app, downloading the APK from apkmirror and turning off “auto-update” for the app in the google play store. This fixed the issue for me. Seems like the Nov 4th version of the app broke notifications and connectivity to the fitbit in general. I tested and now SaA and the companion app are talking to each other again. :smile:

1 Like

Hi Andrew, thanks for the suggestion, I’ll give it a go but I don’t have high hopes considering I still have notification functionality. It’s worth a shot though, I’ll let you know how it goes.

1 Like

My Fitbit - SaA has been broken for a few days, nothing has helped, restarts, reinstall and so on.

After reading this I downgraded my Fitbit app to 3.8, and now it works.

I had no problems with Android Notifications, only Sleep.

1 Like

So downgrading the Fitbit app worked and now sleep connects to my Fitbit. Thanks Andrew and humlan for the suggestion!

this worked for me as well! thx for the suggestion!

I have also downgraded fitbit, but it works as bad as before.
I do not know what is actually wrong.
Sometimes the watch could connect. Sometimes not.

I second that. Tried with both versions and have difficulty getting the Versa 1 to connect consistently. Sometimes after connect it drops out in the middle of the night and no acceleration and HR data is recorded.

Hello everyone and sorry for the late post.

Fitbit SDK 4.0 is out now. This means that support for both Versa 2 and Versa Lite is possible (for Lite, that means the accelerometer is fixed).
This SDK (which is accompanied by a firmware update to all watches) has a completely rewritten communication stack which in theory should be much more stable and hopefully without disconnections. We’ll see on that.

However, the latest Fitbit Android app (v 3.9.1) has introduced a serious error (which Fitbit staff knows about) that prevents communication between the watch and our Sleep app on the phone altogether.

So I’m kinda reluctant to release the new update of the Sleep app right now since in order to make it work, you’d have to downgrade your Fitbit app to version 3.8. (get it here)

If you want that, please let me know and I’ll release it nonetheless.

1 Like

Okay that was dumb from me to ask. Version 1.6 released at the usual link

Hope to pass the fitbit review this time so it can grow out of beta.

Version 1.6 release notes:

  • Built on the latest Fitbit stack so communication stability should be improved (however sometimes the Fitbit Android app still clogs up and you have to force close it and restart)
  • Added support for Versa Lite and Versa 2
  • Fix: After dismissing alarm, the watch app should close properly
  • Major refactor of the companion part so concerns are now properly separated
1 Like

@jiri-urbandroid Thanks for the update! Your post makes the downgrade of the app on Android necessity make sense. I appreciate the insight on that. Question, if we update to Version 1.6, should those of us that had issues and downgraded update our fitbit app to use your new 1.6 Version?

I’m a bit hesitant right now to update fitbit’s android app since it appeared to be breaking much more than just your companion app.

Just recognized, that this is working, even when ,you think it’s not…
I always tryed to test the fitbit sensor, but you shouldn’t do that.

Just start your sleep, when you select FitBit as device.

But of cause follow the instruction of the developer and it will work very great.

And @jiri-urbandroid after I made the mistake written in the comment, the whole setting section “sleep” just disappeared.
I had to reset the app and restoring an Backup

I’m a little bit unhappy about downgrade, because I have to manually update all other apps I need…
I hope the problem will be solved soon.

@Andrew9mb No version of Sleep will work with the 3.9.1 Fitbit app. Anyone who downgraded (or didn’t) should update to the latest version of Sleep on watch v1.6.

At this moment a new version of the Fitbit app (3.10.1) is available, but the fetch() call (which is the core function through which the watch app communicates with the phone app) still doesn’t work.

@Martin_Strell yes I hope so as well :confused:

1 Like

@Martin_Strell Here’s a tip, go to the Fitbit app in the PlayStore.
Click the three dots in the right top corner.
Deselect Auto Update.
And Everytime you click update all, a window will pop up and ask you if you really want to update Fitbit.
Just click skip and you’re done👍


Thank you for the tip :blush::+1:

Our app has been approved for publishing on the Fitbit App Gallery. That’s great news as it means that it will be available through search in the Fitbit app. However at the moment the core issue of connection between watch and phone still persists due to a big in the Fitbit Android app.

So I’ll defer publishing the app until the bug has been fixed on the Fitbit side. (They actually already thought they fixed it in 3.10 of the Fitbit app but have been told by multiple developers that they didn’t - see if interested.)


@jiri-urbandroid is there any update on the apps being updated? Has fitbit fixed the issue yet?

They haven’t yet but thanks to our reports they’ve been able to reproduce it in their latest version and I have high hopes of the issue being fixed in Fitbit app v3.12.