Can't start Wear OS app on Fossil Sport

Detailed description of the problem:

I have the Sleep app on both my Android phone (Samsung Galaxy S20+) and my Fossil Sport (FTW4019). The Android app opens and works as expected, however the Wear OS app does not work at all.

I am asked whether to allow sensor access - which I then give access to - afterwards I see an image of a moon with “Starting” for a very short period (` 0,x - 2 seconds) and the app closes / I’m back to the App Drawer menu. Clearing app data and force stopping the Wear OS app did not help.

Steps to reproduce:

  1. Install Sleep companion app on Fossil Sport SmartWatch
  2. Try to open app on Watch

-> App does briefly open and then closes immediately again.

Version of Sleep as Android:

Android app version: 20200606
Wear OS app version: 3.1

Wear OS by Google version (Watch): 2.17
Home App version (Watch):
Google Play Services (Watch): 20.24.14 (050300-319035315)
System version (Watch): H MR1
Android security patch (Watch): April 1, 2020

Hello Peter,
thank you for reporting and sorry for the troubles.
Would you be willing to send us the wearable report, that will help us investigate this issue?
"To submit a bug report, you’ll need to open up the menu of the Android Wear application on your phone. Once the app is open hit the menu button, and and there will now be a section for “report wearable bug.” It should be obvious what you do at that point. The steps that follow aren’t too difficult, although they’re not exactly straight forward either. Make sure to wait until you feel the watch buzz after hitting the button to submit and report bugs, you will feel the watch buzz three times.(Android Police says it takes about 30 seconds, so have a little patience) After you see the message pop up on your watch that says to touch to share bug report, you’ll want to swipe to the left to open and share, which will send a notification to your connected device allowing to you a tap-to-send option and thus letting you select your share method. "

“A Google representative reached out to inform us that the bug report feature only appears if your phone is also in developer mode (tap repeatedly on the Build Number in the “About Phone/Tablet” menu). You may need to enable developer mode on Android Wear as well, as one commenter points out and allow ADB debugging.”

Hi, I’d like to add that i have the same behaviour on my new Ticwatch Pro 4G.

install app from play store on watch,click open, “allow sensor” click the tick, screen goes black.

Other things tried:
try to clear data, and grant sensor permission from apps settings, then load again, i see a flash of the app screen, then returned to the previous screen

To confirm my versions:
Wear OS app version: 3.1
watch model: WF11018
Device name: TicWatch Pro 4G 0274
Wear OS by Google version (Watch): 2.17
Home App version (Watch):
Google Play Services (Watch): 20.24.14 (050300-319035315)
System version (Watch): H
Android security patch (Watch): 1 November 2019
(no further watch os or play store updates available to download/install)

I have been able to create the bug report using the process you describe, but i do not know whether it contains potentially confidential information. should i attach it here, or how can i send this to you?

Thanks in advance!
Karl Tremain

Hello Karl, if you have the wearable report, please send it to our, we will look into this. Many thanks!

Hello guys, I did just check the code and we have no chances in the Wear OS code since January 2020… so I expect this is probably some issue update a Wear OS update… we will find out more if you send the wearable bug report where we hope to see the error…many thanks and sorry for the issues…


thanks for the quick responses. I submitted a bug report to the mentioned email address. Hope it helps!


email is on its way, but in advance, i extracted this part of the bugreport that looks like it shows the crash:

07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: FATAL EXCEPTION: main
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: Process: com.urbandroid.sleep, PID: 10826
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: java.lang.IllegalAccessError: Illegal class access: ‘’ attempting to access ‘’ (declaration of ‘’ appears in /data/app/com.urbandroid.sleep-qxyQtOxt9KBN5Cs8iesyLw==/base.apk)
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at com.urbandroid.sleep.wear.service.SendMessageTemplate$
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at android.os.Handler.handleCallback(
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at android.os.Handler.dispatchMessage(
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at android.os.Looper.loop(
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at java.lang.reflect.Method.invoke(Native Method)
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at$
07-22 12:35:23.131 10059 10826 10826 E AndroidRuntime: at


Many thanks… I see the exception as well… in the code we use a deprecated method to send messages to the phone… so maybe this just stopped working with the latest update of Wear OS or latest Play Services… I will try to update calls to use the new APIs so hopefully this will resolve the issue… If you would be willing to try a test version I will send a link here… many thanks for reporting…

1 Like

Absolutely would be happy to try a test release - my play store account is already signed up to the beta channel if that helps?


Hello, I did rewrite it blindly as I don’t have a Wear OS device around to test… So not sure if it will work…

The new APK is available here…

Not sure how to force an update on watch… I guess you could uninstall the app from the Play Store app (apps on phone section) and than install again… the version number should be 3.2 (previous version was 3.1)…

In case you would be able to sideload the APK, I’m also sending the link to the Wear APK:

Thanks very much for the updated APK. It works now and is able to start!

I have to say this was the fastest fix I ever experienced, hats off and thank you very much!


Thanks for the new version.

I was able to get the new app version for my phone from the play store, but on my phone it just gave me v3.1 again.

I have now sideloaded the v3.2 APK via ADB, and can confirm that it starts perfectly, and connects to the sleep app on the phone too.

Thanks for the speedy reply and update! :slight_smile:


I cant find any sort of donation link to say thankyou for your speedy reply, so i just purchased the unlock on google play as the closest thing i could find.

Hello Everyone, big thanks for testing this, great news it is starting - in fact this is a big surprise after the blind changes I did :).

This was bigger rewrite so I would not be that fast it may start but I think it may need some more tests to see if it sends all data and alarms work…

Thanks to @lenka-urbandroid I have a Wear OS device now so I will also do some tests…

Big thanks for all your help on this…

Hello Everyone, there is a bug in the version I sent earlier… this bug affects activity data collection… I already have a fix, now I’m testing it and I will release it if it looks good and update this thread with new links… sorry for the issues…

Hello, the new app APK with the fix is here:

and the related Wear APK:

I’m now releasing this also into the BETA channel if anyone prefers to receive the fix from the Play Store…

Hi, I tested over night and have a nice good looking sleep graph with the latest version. Also did more tests with alarms and everything seems ok… Anyone else had the opportunity to give it a try? Many thanks…

My test last night was with v3.2, and i think i saw the bug, i only got “awake” and “deep sleep” recorded.

I’m just waiting for my watch to show an update available, and will test tonight. if play store doesn’t have the update for me by this evening, i’ll sideload it again so i can give you a proper test for tomorrow.