Amazfit gts and sleep tracking not working ANYMORE

A detailed description of the problem:

Since the latest update of Sleep as Android I have been having issues with my Amazfit GTS and sleep tracking, for some reason it is not longer sending the accelerometer data, hence, it only wakes me up at the end of my alarm and not during the 40 min smart period I had set (When before it used to do it).

When trying to test the accelerometer I spend 10 min+ stuck in the Test Sensor Wearables with the loading ring, but then, when testing the accelerometer from the phone or the sonar it happens very fast.

Steps to reproduce:

I have uninstalled and install previous versions of the app, I have tested the accelerometer and gyroscope of my watch using the compass functions to see if there is something wrong or not with it. I have used both app amazfit tools and also notify me & fitness to see if there was any issue with the accelerometer being recognise by one of the other. No luck so far.

Also I have my phone set up so Sleep as Android and any of the components for sleep tracking are set to sleep or kill in the background by Samsung. As I mentioned previously I have been using this already for a year with no issues.

Version of Sleep as Android:

I am using the latest available version on the Google Play Market (20200330)

Update 1:

I managed to downgrade the software version of the Amazfit GTS to stock, and also I have downgraded the Sleep as android app to the last one available before I had the issue, ad it was working, now I have updated to the latest available one and it is still working, hence I have came to the conclusion that actually it was the firmware update of the watch.

I’m having the same issue on 2 Android One phones
Sleep as Android doesn’t detect the sensor and it makes the bluetooth to switch off.
I reinstalled the last beta of Sleep as Android, reinstalled Amazfit Tools, reset the watch…
Not better…

Update 2:

After some testing I have confirmed that it is the Amazfit software, for some reason, previous versions such as 0.0.8.37 work completely fine, but latest updates such as 0.0.8.76 and forward they seem to create this issue, I have not tried with older versions to see at which point and to which version my watch updated when the issue occurred.

If someone wants to do some testing, download the Notify & Fitness app and go to this website to find all the firmware needed.

You can flash the firmware (Stock only) directly from the Notify & Fitness app

What app do you use to pair the phone? Amazfit App ou another?
I’m trying to downgrade, and as soon as it reboot, it updates directly to the new firmware again.

Do not log in into the app Amazfit again, if you do so, force the stop, as soon as it is updating and turn off and on the watch and only use the Notify and Fitness app

If I do so, my GTS is stuck in “open the app and check for updates”
Maybe I have a problem with the last security patch on my android on too

Guess, I have done it and as soon as it says on the watch updating firmware I force stop the app and reset the watch, and it is good to go. Tested it yesterday and accelerometer works completely fine.

After disabling bluetooth 2 or 3 times, it doesnt ask the update anymore.
Tried with 0.0.8.37, and yes, sleep tracking.
I hope that the dev team can solve the problem really fast or for the next firmwares.

Hello folks, I can confirm the issue on Amazfit GTS after the firmware update on the watch in combination with Tools & Amazfit… It seems like after the update BT on the phone is crashing - turing off after a short time… I will try to contact Zdenek Horak author of Tools & Mi Band if he has any ideas about this as he is the ultimate Guru here…at the moment I do not have any ideas on how to workaround this on Sleep as Android end…

Hey, thanks for replying after my testing I deduced the same, that for some reason it was not working with new updates, but indeed the day I woke up I saw that my bluetooth was being turned on again, and it was never off. So this matches your argument, so far it is working as supposed with the stick firmware.

Folks Bluetooth sniffing genius Zdenek Horak (Tools & Amazfit) is on it… so lets cross our fingers for him…

This is good news, thanks for the fast update

Good news everyone :), seems Zdenek Horak has a fix for the issue. Xiaomi changed the communication not-really-a-protocol…the BT on/off issues were just a side effect… and the really good news is he has now released the fix 100% to production so you should get it within few hours from the Play Store…

The fixed versions are:
Tools & Amazfit 4.9.0
Tools & Mi Band 4.5.0

It seems not just GTS is affected but also GTR (and I expect to see more devices over time getting this change with firmware updates) but we could not test it on the GTR so if anyone can confirm the fix that would be great…many thanks for reporting and testing this. Big thanks to Zdenek!

Oh man, this is great, I am so happy I have chosen Sleep as Android for so many years, thank you to Zdenek and also the team at Sleep as Android I will be testing it soon

Big thanks, very much appreciated, please let us know if the issue is fixed for you…

It would be nice to notify the dev of the Notify and Fitness app for Amazfit about the issue too.

Also I would like to add in my very first post that Sleep as Android and any of the components for sleep tracking are not set to sleep and be killed by samsung. Just picked up that mistakes

So cool and fast to solve this little problem.
As soon as the new version is on PlayStore I test it.

Allready updated Amazfit GTS firmware and Amazfit Tools
I try this night

You can try now, put a random alarm and activate sleep tracking, if the phone shows you the graph of the accelerometer then it is fine