Add ability to enable/disable alarms via tasker plugin

i used a shell command i found on reddit to do this previously, but it has stopped working since i updated my phone to Android 14 and i have no idea how to troubleshoot, but it’s would be much nicer if this feature was available. i actually use the “automate” Android app, but it is compatible with tasker plugins.

Hi @bluemonkeysuite07,
I am not sure which intents did the command use, but does it mean it is no longer triggered, or no longer received by Sleep app?
We support both Tasker, and Automate.

We have an intent API (details here), the alarm disable intent is:

Disable Alarm (when not currently ringing)



    alarm_label: String representing a label of alarm to be changed. If there are more such alarms, only one of them is going to be changed (no guarantees which).

    alarm_enabled: Boolean saying whether alarm should be enabled or disabled.

We do not have an intent for enabling alarm at the moment, so that one counts as a feature request.

The command is trigger just as it always did, but the alarm is no longer enabled and disabled

this is the command

i am quite in-experienced with intents in automate. could you show a screenshot similar to mine showing how exactly to send the intent from automate to sleep as android to disable an alarm?

what am I doing wrong?


Hi, sorry I was on vacation last week.
If the intent is sent, but not received or completed by the Sleep app, please ideally reproduce it, and send the application logs (Left ≡ menu → (?) Support → Report a bug). Is the intent API enabled in settings?

yes it is definately still enabled

ok i sent the bug report


can you check how to correctly send intents in automate

Hi, so according to your logs, there is no alarm saved - the intent can enable or disable the alarm, but it won’t create a new one.
Also, there seems to be a warning in the EXTRAS section (the exclamation mark) in the automation app, it looks like a syntax error. This depends on the syntax the automation service is using.

i have 5 alarms set

so you do not support the automate app?

Sorry about the alarm, that was my mistake - I forgot we are logging only the alarms active at the moment. The intent did not send the extras, so the Sleep app did not have any information about which alarm should be changed - such intent cannot be executed.

We have integrated a few apps for automation, including Automate.
But we are two developers, and it is not in our power to maintain all our apps, and also provide support for individual DIY automation solutions. So it is up to the users to configure the setup within those automation apps. I hope you understand.
You can find how to set up extras online, for example here:


so something like this? i have no way to debug to find the correct syntax required, unless you can tell me how to figure out what is required

Hi, I don’t use the Automate app, so I don’t know their syntax.
But they have an on-line documentation, where you can find everything explained. There are also some example recipes available online on their Reddit forum.

so this was working with the shell command, why did it stop working?

Did it stop working after your system update or our app’s update?

i can not be 100% sure