Wearable S3 Frontier - stopped working

Detailed description of the problem:
The app isn’t opening anymore on my watch, worked fine up till a few days ago. i have tried uninstalling and reinstalling and even resetting the watch to factory defaults.
When opening the application on the watch it shows “Starting tracking…” and stays there.

Steps to reproduce:
open the app on the watch

Version of Sleep as Android:

Hi, which version of the addon do you have installed?
Are all components allowed to run in the background, and launch?

All optimizations need to be disabled for Sleep, the addon, Samsung Accessory Services, and Bluetooth.
In some cases the addon won’t be able to launch properly, if it was force stopped before.

The addon did not have any updates in the past months, and you seem to have Sleep app from 20th February. Is the issue more recent? What has changed?

I’m using version 1.3.0, no it hasn’t changed in a long time.
Nothing has changed, I’ve been using the phone and watch for a long time, and just one night it suddenly refused to connect to the watch.

it does sometimes suddenly connect out of the blue, usually if I turn the phone Bluetooth off and on again a few times.

I may have found the issue, looks like battery optimization got turned back on somehow.
I turned it off again and it seems to be working again :slight_smile: