Trouble Connecting to IFTTT

I had previously successfully connected Sleep as Android and IFTTT, but I am having trouble this time. According to the documentation (, once I log into IFTTT, my ID should load automatically and the “IFTTT connected” message will appear…But that doesn’t happen.

When I instead manually enter my ID as per the provided instructions, I still don’t see a “IFTTT connected” message and my IFTTT sleep_tracking_started applet doesn’t trigger when I start an alarm in Sleep as Android.

Hi Wordna,

I’ve just tested retrieval of the key inside the app and it worked for me, so I’m not entirely sure what might be going on. I’m thinking maybe the structure of the site is different for other countries (because we rely on blunt website scraping for key retrieval). So I’d like to ask you if you could tell me what exactly happens when you try to retrieve the key automatically. On which webpage does the in-app browser end up on?

Regarding manually entering the ID - I can see that we actually don’t have the confirmation message in place when you do that. I’ve fixed it for the next release.

But since you say it doesn’t actually work for you at all, I’ll need a debug log. Please send me a debug log using menu > report a bug, it will reach me if you mention that it’s for Jiri.