Tickwatch pro support


#1

I’m a new tickwatch pro user and sleep as android seems to work perfectly other than It cannot read my heart rate. I already contacted the mobvoi support and they told me that sleep as android app would need to gather the heart tracking data from the mobvoi app. So I’d like to request support for tickwatch pro (and possibly the same feature would add support for other tickwatch products as well) if it’s possible for you to do.


#2

I am with you. Possessing a TicWatch Pro recently I would really like to analyze my sleep with my watch. Really can not wait for them to add to the list this wonderful watch


#3

Snap. Just signed up for an account to ask this very question. At the moment, I take off my Ticwatch and switch it off, then put on my old MiBand 2 while I’m asleep. Both feed into Google Fit so I lose nothing there, but it seems daft I have to remove my £200 watch and put on a £30 one to get the heart rate measurement.


#4

I also have this device and have no HR support despite it being a Wear OS 2 wearable.


#5

Wait, the Pro is a Wear OS device. Shouldn’t HR work out of the box with the Wear OS version of Sleep as Android after granting the needed permission?! Bummer, I was planning to get one…


#6

I just got the ticwatch pro a few days ago and I have heart rate tracking in sleep as android. It was a beta option in settings. I turned it on, joined the beta program and downloaded the beta app.


#7

@dranderson, does your heart rate show in your sleep graphs? I too signed up for the beta and am using the beta app, but I can’t get a HR in my sleep graphs with my Ticwatch Pro.


#8

Hello, if your Wear watch does not send HR to Sleep, the problem is most often a missing Sensors permission either on the watch or on phone. First please make sure your have the BETA version of the app. As this feature is BETA only.

Make sure that both phone and the watch have body sensors granted.

a) to grant the permission to the app on phone, go to System Settings > Apps > Sleep > Permissions
b) to grant the permission to the app on watch, just start Sleep on your watch and it will ask you for granting the permission. If it does not, please do the following:

  1. Swipe down from the top of the screen.
    • Wear OS by Google: Tap Settings and thenand then Apps & notifications and then App permissions.
  • All other watches: Swipe left and tap Settings and thenand then Permissions.
  1. Tap on Sleep > Body sensors to turn it on.

If you do not see the body sensor permission on your watch, than the BETA version of the watch app has not yet been synced over to your watch. You may want to uninstall the SleepWear app from your watch and install it again.

There is also a special case: Wear OS requires same permissions on the phone and watch, but the permission of 6.0 only to not force all pre-6.0 users to accept a new scary permission which they do not need anyway. So at the moment HR won’t work when your phone is pre-6.0 and your watch has a higher Android version number.

If you there are no permissions listed on the watch, please, reinstall the watch app as you still have a non-BETA app on the watch with does not declare the permission…


#9

Yes, I do get heart rate on my graphs.


#10

Ta. Petr ended up responding on a different thread…the problem was I had installed the Sleep as Android app on my watch before switching to the Beta version on my phone. I had to uninstall the app from my watch and re-install it in order to get the beta on the watch. Once I did that and opened the app on my watch it prompted me for a permission to access my ‘vital signs’ data. So hopefully tonight it’ll be all good.