Task doesn't get triggered using ~REM event with Tasker app

Detailed description of the problem:
I made a profile in tasker to play a sound track on loop when REM stage gets detected using sleep as android plugin, but it never gets triggered, and I even checked the log file in tasker and shows that it never activated.
Steps to reproduce:
On tasker app go to profile, then press on plus button in bottom right corner and select event, then select plugin, next select sleep as android plugin, then in configuration, select “~REM” then for task type in filter" music play" and choose a song, and save profile then click on check mark, then start sleep tracking.
Version of Sleep as Android:

The implementation of events is strange overaly. For example, the “After fall asleep” event triggers only if you set up lullabies in the app. Like why? Why do I need to set up lullabies to trigger this event? It’s totally crazy.

Maybe it works only if Lucid Dreaming is enabled. In that case, you would have to set 0 volume for the lucid cue or play an empty file.

yeah I enabled lucid dreaming mode and it works with tasker now.