Sonar not working on Pixel 3

Detailed description of the problem:
I recently had to get a replacement phone from Google and hand to reinstall Sleep as Android from scratch.

On my previous phone, sonar was working without any problems. On my current phone, every time I try to activate/test sonar, I am told to “Please wait…”, then I get a pop-up that’s says “MONO_18 18000 - 18000 failure”

This happens with all frequency options: F18/19/20/18-20.

Steps to reproduce:
Go to Settings > Sleep Tracking > Sensor > Sonar > Select any frequency

Version of Sleep as Android:
20190610

1 Like