Sonar is audible, strange sounds when using sonar - Sleep as Android

We have reports that on some device you can hear audible artifacts during sonar tracking. It sounds like this: audio::/assets/audios/sonar.mp3[options="controls"]


This is a companion discussion topic for the original entry at https://docs.sleep.urbandroid.org//faqs/audible_sonar.html

Have this problem too, since today. Before, everything worked well with F18, 19, 20, 18-20 for months but suddenly something went wrong. During tracking, sonar got deactivated and now strange sounds are emitted from every frequency and no signal is detected. No software / firmware updates made. Very strange.

I use Samsung Galaxy A51.

1 Like

I also have this issue, using a Pixel 6. But isn’t 18-22 kHz still audible for most young people? I remember fiddling around with Audacity a few years ago and was able to hear up to 23.5 (I was around 30 years old back then) so i suspect this maybe isn’t even a postprocessing issue of the phones.

I just downloaded the app last night, and didn’t realize it didn’t use sonar automatically. Tested it today and every setting is FULLY audible.

And not like a little audible… it’s loud as hell and super obnoxious. Really disappointed since that was the feature I actually wanted it for.

Like another commenter, I also have a Samsung Galaxy A51. I might try using it with my old Huawei Honor 6x and see if that makes a difference.

@Katnap

Thank you for your message and sorry for the troubles.

We have reported that on some devices you can hear audible artifacts during sonar tracking. Some of the signal gets into the audible spectrum probably due to either insufficient quality of the speaker or some post-processing which is applied to the output on your device firmware.

We have also some reports that Sonar can get audible suddenly during tracking in the night. Unfortunately, we are not sure why this could happen, we only have very few such reports and we are not able to reproduce this on our phones.

To make any audible artifacts less likely, please go to Settings > Sleep tracking > Test sensor , and first of all try to lower signal strength and if that does not help, try a different frequency (from the drop-down menu list).
Some phones have troubles with the dynamic one (F18-20), but work well with others. From our users’ feedback, seems like the best frequency for troubled phones is F18.
If you find the least affected frequency, you could try lowering the volume a bit (the sliding bar). But keep it as high as possible to maintain reliable results. If the volume needs to be adjusted, always confirm that sonar is still working - ideally, after you change settings, try to sit calm in front of the test for few seconds and then move slightly - do you see a spike?

Please let me know your feedback. Many thanks…