Some issues with Samsung Galaxy watch 6 and galaxy phone

Detailed description of the problem:

  1. The watch app won’t show the alarm overlay. Every time if I want to dismiss the alarm, I will have to skip the sleep mode by opening the watch main screen, then tap the alarm button and stop it.
  2. The alarm sound comes from the phone rather than the watch.
  3. The watch is not vibrating once the alarm is triggered.
  4. The app is battery hungry on both watch and phone. Too hungry. I don’t want the sleep tracking as it’s already done by the Samsung health app. Sleep as Android should be able to pull the info from there rather than doing the sleeping record separately. This may save the battery if both watch and phone won’t do the double recordings.

Steps to reproduce:
Set up a alarm on the phone with default settings.
Version of Sleep as Android:


Here is the screenshot of the battery usage on the watch after running for nearly 2days continuesly. I never opened that app. So it consumes battery heavily in the background.

Another trouble is if the watch is disconnected with the phone, the alarm won’t be triggered! That’s a disaster if I charge my phone in the living room while sleeping.

PS The vibrating issue has been found and I can enable it in the app settings. The sleep tracking can also be disabled. Although I can still see the sleeping records(assuming it’s using the data from the watch health app)

Hello Neil, was Sleep app not used at all, not even for alarms, or vibrations for alarms? We do not have any issues reported so far. What are the other apps in this list?

If you start the tracking and the connection is lost, the alarm should have been triggered by the addon. This sounds like the communication between the phone and the wearable did not happen at all, or the addon has troubles running.

The full-screen alarm is not possible, the permission needed for this has not been implemented yet. If you tap on the icon, the full screen can launch.

The alarm on the watch does not have sounds, only vibrations.

If the wearable is not vibrating upon the alarm on the wearable, you either have the alarm start delayed in the settings, or the wearable is in the Bedtime mode and does not allow vibration.

Hi Lenka,

Thanks for reply. I am intended to use the sleep app for alarm. So I don’t have many functions enabled.

In the alarm settings, Terminate tracking is on. In the universal settings, I enabled full screen alarm, set Automatic sleep tracking to Bedtime. Sensor set to Accelerometer. In the Wearables sub-settings, set Galaxy Wathch 4,5+. Vibe once connected on, and leave the rest of the items disabled.

I don’t manually turn on sleep tracking on either phone or watch before going to the bed.

I usually charge my phone in another room, so it’s common to loose connection between the watch and phone while sleeping. I’m not sure what addon were you talking about for the alarm.

Last but not least, my watch automatically set to DND and sleeping mode during the night. This shouldn’t cause the problem because it used to work if the watch are connected to the phone. I also don’t set any app restrictions, maybe you can shed some light on where to check those settings?


Hello Neil,
If you are not tracking, and your wearable is not connected to the phone at the time of the alarm, the app won’t be allowed to trigger the alarm.
If the tracking was running, it is the only exception - we are allowed to save a backup alarm in case the connection is lost. This does not work when the tracking is not used.

The addon on the wearable is the Sleep as Android app installed on the wearable. It is not a stand-alone app, but only an addon for wearable tracking. Since you see the notification for ongoing alarm, you have it for sure.

The restrictions are not something the users need to configure - they are put there by the vendor, and the users need to disable them to allow background tasks. This depends on the vendor you have. Pixels are fine, Samsung + Huawei + Xiaomi +1+ have tons of restrictions. You can find details at guide on how to solve this at

Sleep mode does not allow vibrations, so it is not recommended to use it with Sleep. It will block the alarm vibrations. And since they have not released API yet for this mode, we cannot control it, or disable it for the alarm.
DND is standard mode, and the apps can be set to override the DND for alarms. So this one is fine.