[Solved] Sync from Google Fit broken


#1

Detailed description of the problem:
Sleep data added to Google Fit by other applications is not pulling into Sleep as Android anymore.

Steps to reproduce:

  1. Add sleep data to Google Fit using another service that supports it. I used a modified version of this python script to add data from Fitbit to Google Fit: https://github.com/praveendath92/fitbit-googlefit
  2. Open Sleep as Android, go to Settings, Services, and Sync now

Version of Sleep as Android:
20181212

This seems to have broken at some point between Sept 24, 2018 (when Google updated their API to block REST clients from sending a packageName) and Dec 11, 2018 (when I realized it had broken and fixed my daily sync script). I have since backfilled the sleep data for that time range, but Sleep as Android still doesn’t see it.


#2

Seems like this was an issue on Google’s end. I got an update to the Google Fit app last night and suddenly SAA started pulling in all my sleep sessions again. I’m guessing they fixed something server-side at the same time.