SNOOZE not turn off HUE wake-up-light

From Anonymous on 2015/07/17 08:32:26 +0000

If I activate a snooze, the ringtone and the light go off until the end of snoozetime and starts again. But in real the sun would not turn back behind the horizon.

  1. It should STAY ON if I activate a snooze, not start again with the end of snooze.

  2. And I hope it’s possible than that the light go on to grow up gently (how I choosed it in the sound option). OR at least stay and wait in the actual sunrise position until the next snooze alarm sound starts.

(There are so much possibilities with hue and Sleep as Android. You can get it! great work!)


Copied from original feature request: http://urbandroid.uservoice.com/forums/264867-sleep-as-android/suggestions/8907325-snooze-not-turn-off-hue-wake-up-light

From Anonymous on 2015/09/13 23:12:40 +0000

You could set two alarms, one silent with the light that you'll never snooze and a regular one with sound. What do you think?

It would probably be easier and more user-friendly to make this a toggle in the smartlight settings than expecting people to set multiple alarms with different loudness and snooze settings.

1 Like

Yes I would love this feature! Just got the Hue smart-lights and am pretty disappointed that you cannot keep the light on during snooze cycle. Not sure how a different app or a second alarm would work with the smart wake up feature either.

This feature was added in the August 30 update. Go to settings > smartlight, and set “light up after” to “both”. This causes the artificial sunrise to ignore the snooze button.

Thanks for adding the feature. However I am not it is working as intended on mine. I have it setup at both which keeps the light on after I click snooze or turn off the alarm which is good.

However, the light turns off and restart the sunrise cycle after the end of the snooze period when the alarm starts again. This is not desirable for me. Like it was said before, the sun would not go back below horizon Haha. It would be ideal if there was another toggle preventing that or just changing the logic to avoid that. I don’t see why someone would want that. Thanks in advance!