Sleep Uses Phone Instead of My Wearable

Hi guys, Sleep As Android uses my phone to record sleep data instead of my wearable even after it has confirmed the connection with my wearable (vibe once after connected enabled).

I’ve tried Sonar and normal Accelerometer sensors and neither got it to use the wearable, which means no heart rate graph, and there are Sonar breath graphs.

The Miband 5, Mi Fit app and Tools & Mi Band app can measure heart rate and continuously monitor my heart rate throughout the day no problem.

Steps to reproduce:
Phone: Sony Xperia XZ 1 Compact (G8441)
Android version: 10
OS: Lineage 17.1
Wearable: Xiaomi Miband 5
Integration: Tools & Mi Band
Permissions enabled: all permissions needed by Tools & Mi Band, Mi Fit and Sleep are all set to “Allow while app is in use”

Version of Sleep as Android:
20200606 (22100) Premium

Thank you so much for reading.

could you please check if the wearable is selected in Settings -> Wearables -> Use wearable?
If this is set up properly and the wearable is not connecting, please use Left ☰ menu > Report a bug, and send the application log to our support.
Thank you.

Hi Lenka, thanks for the reply. I somehow fixed the problem recently.

  1. Updated Miband 5 firmware
  2. Both Miband Tools and Sleep As Android were already the latest versions, so no need to update.
  3. Power off and power on phone

These were the steps I took. I guess the issue might have been a weird pairing issue with the app and the Miband.

Well, I am not sure which step did the trick, but I am glad it is working :slight_smile:
If you encounter any trouble, let us know.
Thank you and have a great weekend!