Sleep as Android + Google Fit/Health Connect

Good day.

All out of sudden, my SaA app can’t read data from the Google Fit. It can write, but I can’t add data from Google Fit to SaA app. Played with all settings, Health Connect sync read/write permissions, still no data from Fit gets to the SaA app. My setup: garmin app sends data to Fit via Health Sync, then SaA was able to read data from Fit and transfer it to SaA.

so basically, I cant imported data from Fit.

SaA version - sleep-20231221-prod-release
Phone: Google Pixel 7, latest december update.

Last time i could get data from Fit was 3 december. After that the result of importing data from Fit = 0.

1 Like

Can confirm I have the same issue. Sleep used to be able to grab data from Health Connect (either from Fitbit or Fit) but no longer does. Using Sleep version 20231023 on a Pixel 7 Pro, fully updated & stock.

I have the same issue, until December SaA was reading data from Google Fit. The data in Google Fit is stored properly by my smartwatch, but SaA can’t sync/read Google Fit anymore. I tried disable/enable but didn’t work. In my notification bar it shows downloading data until 100% but it gets stuck there and doesn’t disappear until I clear the notification by myself. App is updated to the latest version. Phone: Poco M4 Pro

Same set up and same problem here, it used to work perfectly but now my sleep trackings from Google Fit/Health Connect aren’t synced to SaA anymore.
I tried, disabling-reenabling sync, removing and resetting permissions, still nothing.
Last sleep data synced was on November 25th 2023.

SaA version : 20231221 (230314) Premium BETA
Phone : Pixel 6 - Android 14 - build UQ1A.231205.015

So still no workaround I guess? No way we can get data from Fit or Health Connect?

Hi, Google Fit introduced a new set of rules, that is not acceptable for us (for example, connecting with addons is not allowed, which means we could not support any wearable at all). So we will have to drop support for Google Fit very soon. Right now, they are even limiting syncing data from other sources - so we can read our data, but not data uploaded by other apps.

Health Connect should work, though. Does Sleep have both read/write permissions for the data? Could you please force a manual sync, and send us your application logs (Left ≡ menu → (?) Support → Report a bug). Thank you.

Sleep as Android does have read & write permissions to Health Connect. I just did the forced manual sync and sent you the bug report. Android even shows recent Health Connect data access from SAA after manual sync, but no sleep data show up in SAA

Hi, the latest BETA of the Health Connect app requires the BETA version of the Sleep app.
Their BETA changes quite often, and their latest update changed the API completely. To keep Sleep in alignment with these Google updates, please, join BETA for Sleep (details here, or at


Hello Lenka. Can confirm, I had been trying for weeks to sync Health Connect data (through Nest Hub) on the release version of SaA, but could not. The moment I switched to the Beta version of SaA they synced almost instantly. Thank you!

Perfect, great news!
The change they made was pretty major, so the old version of Sleep was not able to sync any data.

1 Like

Yepp, can confirm - sleep data started to sync on the latest beta, but no HR/breathing, just the sleep graph. Well, that`s probably google new restricitions, i guess.

For me HR was also synced, probably because I imported from Fitbit and not Fit (Nest Hub). I’ll try this workaround to see if it works: have Fit (essentially the Hub) sync HR/breathing rate with Fitbit, and then have Fitbit sync the info to SaA. Hope it will work, will report back :slight_smile:

Edit: cancel that, FitBit cannot read breathing rate :confused: