Sleep as Andriod (on Huawei P30lite) does not find sensors Ware OS device Fossil Gen 6

Detailed description of the problem:
Hi Sleep as Android team,

I could connect my Fossil Gen 6 smartwatch with my P30lite successfully and can use all its functions including Google Fit and its on sleep tracking from Wellness. However, I would like to use Sleep as Android instead for my sleep monitoring because to me it’s far more better.

I configured “use wearables” from the menu and tried to test the sensors, but it doesn’t find them at all. The search goes into timeout finally. :frowning_face:

Can you please help me out solving this? Do I have to apply any work-around making it work?

Thank you in advance for your support!

Kind regards,


Steps to reproduce:

Version of Sleep as Android:
20220222 (22622) Premium

1 Like

Hello @berion , can you please check that the Sleep as Android app is installed on your Fossil Gen 6 watch? This is required to make this working…

Hi Petr,

thank you for you support. Sorry for delay in answering. I was busy with other things at the weekend.

The application was installed as it looks like from the Google Play Store. :pensive:

Could I do further checks?



Hello @berion, do you see an icon of Sleep as Android on the watch? What happens when you start the app on the watch? this should startt sleep tracing on the phone when Settings > Wearables > is configred as Wear OS… Many thanks…

Hi Petr,

thanks for replying continuously. I appreciate that very much!

Unfortunately, I haven’t seen any new icon on my watch. Sorry, I am new to Wear OS and thought if I find it installed at the PlayStore on my phone to my device “Smartwatch”, it is on there. But it seems to be not there at all. I only can find the pre-installed applications and I only could manage to switch watch faces to customize my watch.

So how can I make sure that application is installed on the device properly? Where should it appear? The settings insise the Sleep as Android application on my phone I already set to Wear Os from the beginning because I haven’t seen any other option that fits to my configuration. So that actually should be fine. But here I could not make the connection to the sensors when I click on the test button. So the problems seem to be with the watch, isn’t it?

Thanks in advance!


Hello @berion, please open the Play Store app on your watch, search for Sleep as Android and tap on install. This will install the watch part of the app which takes case of the sleep tracking service and gathering data from sensors over night, without the app this won’t work.

Did you manage to install the app on the watch?

Thank you for late answering. The watch was my birthday present and I had to wait some days because it was covered :stuck_out_tongue_winking_eye: the last couple of days. Yes, before I could not found Google store on my watch and thought installation works from remote out of the phone. Thanks. Problem solved. Kind regards, Alex