SaA No Longer Connects to Fitbit Versa 2 For Sleep Tracking

  I have been using the Sleep As Android app (Premuim) on my Fitbit Versa 2 for several months now. As of July 27, 2022, the app will not connect to to the Android app on my phone when I manually start sleeping. I start the app on my Fitbit, click on the "Start Sleep Tracking" app on my Fibit, and I get the "Waiting For Connectivity" message. After waiting for the progress bar on this screen ( takes about a minute ) to reach the end, it starts sleep tracking but NOT with the Fitbit ( i.e., it starts sleep tracking with the phone only and not my Fitbit ). I did this numerous times and the result is the same every time. I have neem using sleep tracking with the Sleep As Android with my Fitbit almost ever night for months and it has worked fine until yesterday (July 27, 2022). I made no changes to the phone app or the smartwatch app recently.

 Below are the steps I have taken to solve this problem :
  • verified that the Use Wearable option was enabled in the options menu with Fitbit selected as well.

  • verified the bluetooth connection between my Fitbit and my phone ( Motorola Moto G Stylus 2020 version with Android 11 )

  • verified that “Manually Only” is selected in the Sleep Tracking section of the Options menu

  • uninstalled and reinstalled the latest version of Sleep As Android from Google Play store and then verified all the settings in the Options menu of the Sleep As Android app on my phone

  • uninstalled and reinstalled the latest version of the Sleep As Android app on my Fitbit Versa 2

  • rebooted my Fitbit

        None of these measures listed above resolved the problem. Has there been any changes to the Sleep As Android phone app or the Fitbit version of the Sleep As Android app? Is this a new bug?

I found this on another post: Fitbit was working with Sleep, stopped a week ago

My versa 3 is having the same issue.

Hi, there is a bug in the last update of Fitbit app which broke access to local webserver on the phone, so there’s no way for Sleep as Android to communicate with the watch. We have a confirmation from FitBit support, that they are working on a fix.

You can either downgrade the Fitbit app to version 3.58 or to wait for the next update.
You can get the previous FitBit 3.58 APK is here 1
(from Softpedia, install at your own risk, but they claim it’s safe)​.
Let us know, please, if downgrading helps.

UPDATE: according to our users, downgrading the app to 3.58 is not working (the FitBit app immediately crashes). The closes update, that seems to work, is 3.30.

1 Like