Restore Purchase

I unlocked the app back in May 2017 (During a discount period)
A few days a I performed a full restart on my phone but now I can’t unlock the app without being charged again, but this time full price. How can I fix this?

In-app purchases are notoriously buggy on Android, especially when you have more than 1 account on your smartphone.
The problem is that in-app purchases are always tied to a specific account, and if the app to which the in-app belongs is installed under a different account on your phone, it won’t be recognized. We consider it a bug, even though it is a logical one, not technical.

To get the in-app unlock recognized properly, do the following:

First, we’ll remove Sleep as Android from the wrong account.
Uninstall Sleep as Android (make sure that your data are backed up first! See backup guide)
Start the Play Store app on your phone, go to the Left menu > My apps&games, then click on LIBRARY in the tab bar.
Find Sleep as Android in the list (for easier search, switch to alphabetical ordering)
Remove Sleep as Android by tapping the cross button.
If Sleep as Android was not found in the list, you’ll need to switch to a different account in the Play Store app. Do that in the left menu, using the down arrow on the menu header. Then repeat the steps above.

Now that Sleep as Android is removed from your account, we’ll add it to the correct account.
In a browser on your computer (not on the phone), open up
Make sure that you are signed in under the account with which you have bought the in-app purchase.
Click on install
Now the app should start downloading and installing on your phone, under the correct account, and should correctly recognize the in-app purchase.


Thank jiri
That seems to have worked. I don’t see anything telling me I don’t have the full version.
I’ll let you know if I run into any issues.

1 Like

Hi Jiří,
I have the same problem and already made a new topic for it.
Need help, please.

Vyřešeno, promocode.

1 Like