Redlined: Google Fit Interference?

Detailed description of the problem:

Steps to reproduce:

Version of Sleep as Android:

The problem is visible in the graph. It redlined at approximately 7:54 AM (the crash log pinpoints it at 7:52 AM) and stayed that way. When I opened the Pebble Health app, at first it showed no sleep at all. Sometimes that takes a few minutes to kick in. It took almost an hour today and ONLY AFTER I TURNED BLUETOOTH OFF AND ON AGAIN. This had no effect on SaA. Still redlined.

On a parallel situation - which I think may be the culprit, Google Fit has been acting up badly in the past 2-3 days. It crashes on opening, things disappear, etc. I do not sync directly to Google Fit because in the process, it imports all the Pebble phantom graphs. I use “Health Sync” which takes Samsung Health information from Sleep As Android and then displays them nicely in Google Fit, graphs and all. That keeps my statistics clean.

So there’s a lot of data moving from app to app to app and Google Fit needs to be, well, fit. And it’s not. I have tried everything. Google Fit went buggy. For a whole day it wouldn’t even stay open: crashed on open every time.

UPDATE: Google Fit rushed a fix out today: go get it in the Play Store.

I sent the bug report with graphs. But with Fit fixed, the problem may be solved.

Pebble Sleep AFTER Bluetooth off and on. This is also something to look at.

Thanks for any information you can offer. I think the Fit fix may have fixed the problem.

I wonder if the Fit problems caused the failure last night with SaA.

This cannot be a coincidence.


And yes, I just downloaded “Don’t Kill My App.” :+1:

UPDATE: Google Fit just posted an update and it’s working properly now. :smiley:

We’ll see if that caused it tomorrow. I think it did.