Prevent from turning off not working properly

I’m using the “Prevent from turning off” option, but my sleepwalking figured out how to turn off it haha. I still can turn off if I can be fast enough to touch in the “turn off” button before it goes away again. Is there any way I can prevent from it happening?

Try as we may, there’s always going to be some way of turning off the phone or avoiding the alarm that could be done if you e.g. have a slower or a hogged phone and it doesn’t react as swiftly or if you are extremely apt and agile while sleeping :slight_smile:
That’s why we also offer the motivational wager option - we’re perfectly able to detect an avoided alarm afterwards and the fact that you’re betting real money on waling up is going to have real impact on your morning behaviour.