O2 ring not connecting with latest beta


I had succesfully installed the O2 Ring Add Onn and it was working fine on my Samsung J2 phone until a few days ago when I installed the new beta version.

The blutooth symbol flashes on and off in the place where the heart rate was previously displayed, see attached screenshot.

Is there a work around please ?


Hi Bill,
I expect the SaA team will want a support bundle, i.e. “Report a bug”

Perhaps you could install the previous .apk https://sleep.urbandroid.org/more/download/

Have you confirmed if the O2Ring add on is still indicating it’s connected to the ring?

Thanks for the reply. Main reason for reporting on the forum was to see if any other folk were having the same issue or had already fixed it. Yes I will put in a more formal report, I think the O2Ring addon isn’t formally supported yet by SAA. I get the impression the O2Ring addon app is a serendipitous sort of a thing that fell out of another project and the chap who did it realised it was possible as a natural extension of something else he was working on.

1 Like

Hello. Please, use previous SaA beta version which works with SaA correctly.

Latest SaA beta have multiple data collection feature in test mode with many devices, so right now looks like it broke smth in previous connection mechanism and new connection mechanism isn’t published yet.

1 Like

Hi Den, is the download at the link in your post the same as one of the files at the link in my post above? I ask because your link is to a file not hosted at urbandroid.org.

I do not remember the exact SaA version where O2 ring works, I just have apk file of that version

1 Like

I have seen that same symbol with my Scosche. What I do is disconnect it and reconnect it, sometimes several times until it really gets the message. You probably have tried this. But if not, go to sleep a little earlier to hit “cancel” the recording and then disconnect and reconnect. As I said, perhaps several times until this version of the app gets the message.

As I said, you’ve probably tried this, but if not, it can work well.

Best of luck!

Go and try it with someone else.