No "Delayed Sleep Tracking" for Naps

From Randy Tasajaya on 2016/03/22 22:49:01 +0000

Let me first thank you for developing the app so carefully. This description is a bit long but precise, please stay on.

The “delayed sleep tracking” works wonders. I for example like to set it to 15 minutes. But when doing naps, I think people tend to sleep directly (or at least almost), so in case of naps the “delayed sleep tracking” isn’t needed. But entering “nap mode” will apply the “delayed sleep tracking” automatically, no matter what (yes obviously “delayed sleep tracking” is set by me, for normal sleeps).

It actually can cause problems, for example in my case: “delayed sleep tracking” is set to 15 minutes, when I enter the “nap 15 minutes” mode, the “sleep tracking” will begin 15 minutes after I nap because of the “delayed sleep tracking”, so basically “sleep tracking” just didn’t start at all. In this case the “smart wake up” wouldn’t work, because “sleep tracking” didn’t even start in the first place.

Some possible solutions:

  1. “Delayed sleep tracking” time setting is divided into: (i)when normal sleeping, (ii)when napping
  2. Entering “nap mode” will NOT apply the “delayed sleep tracking”.

Some not elegant solutions:

  1. “Delayed sleep tracking” time setting is a setting in each alarm
  2. In “sleep tracking” mode, just at the beginning, the “window” which shows the countdown of the “delayed sleep tracking” time, whose time can be added for 5 minutes, can be stopped/closed, so that “sleep tracking” begins immediately.

    Copied from original feature request:

From Gabriel on 2016/06/29 08:39:25 +0000

I have been having the same issue! When I wake up in the morning I usually snooze a couple of times and then disable the alarm. To wake up I use naps, but the delayed tracking leaves me with a lot of blank tracking in the charts because my delay exceeds my nap duration. So it would be nice to deactivate sleep tracking for naps!