My graphs are flat - Sleep as Android

There can be several reasons why your graphs are flat.

The actigraphy is almost flat

When you can see some movement on the actigraphy, but the graph is unusually flat: . Sonar - make sure the signal is strong enough by keeping sonar volume at max at Settings → Sleep tracking → Test sensor → blue sliding bar. - you can also try different frequency by choosing other frequency from the ddrop down menu list in Settings → Sleep tracking → Test sensor → Frequency - keep the phone closer to you bed - try different positioning of the phone . Accelerometer - try keeping the phone closer to you.

This is a companion discussion topic for the original entry at

If the accelerometer does not detect motion no matter what you do, consider rebooting the phone.

I find that if my phone has involuntarily rebooted itself due to crashing and come up in safe mode or semi-safe mode, accelerometer is turned off and I must reboot normally to get accelerometer back. (On Pixel 3aXL) if the G logo is grey or pastel when booting up instead of bright colors, this usually indicates to me that some important services will be turned off until I reboot normally.

This thread and the reference in the documentation about “flat graphs” so far only deals with actigraphy. My issue is the hypnogram is flat at “Light Sleep” from the moment I go to bed to the moment I wake up. Except for the super-imposed icons and a totally different noise display, my charts look very much like this:

The actigraphy is active, the hypnogram is flat.

Using only my smart phone (no secondary device inputs).

Using sonar, phone placed about 18 inches from me on a stable surface (which actigraphy shows is more than sufficient).

No recorded any sounds other than in the first 15-20 minutes of bedtime (general tossing for comfort until falling asleep).

I do have a noise event 1 hour after asleep for about 15 minutes, but it wasn’t recorded (why not?). Until 45 minutes before alarm time, noise graph shows an incredibly quiet night with just 5-6 small bumps.

No icons super-imposed over either graph (low breathing, snoring, etc.)

So why is my hypnogram flat at “light sleep?”

Hello, usually, the whole-night-light-sleep graph is a result of too uniform data. In the case of sonar, the signal is either too weak or too distorted to measure your actual movement. Or there might be some other signal interfering. It is not possible to say just from the description, I would need to see the logs and the raw data (Left ≡ menu → (?) Support → Report a bug).

Does it mean the sound is not monitored after a while, or it is monitored, but not recorded?

Not all sounds match the criteria for recording - this depends on your noise recording threshold. If the sound is quieter than the threshold, the recorder is not triggered.