Mostly all data missing

Here is the second portion I mentioned I was going to ask after finishing the first. Sorry for all the screenshots I’m being as informative as I can to see where the glitch is. Basically I enabled health connect and Samsung health in SAA ( the APK ) version because of Samsung health, so after giving all permissions to all apps separately when I uploaded the info it said it uploaded 69 graphs. How on earth Samsung Health only shows 1 recording of 1 sleep time. Something is quite wrong.

Sometimes, the service syncs the data, but shows them with a delay (Health Connect especially). Sadly nothing we can control.
If you saw the confirmation about 69 graphs syncing, then the service confirmed 69 graphs were uploaded.

Please check, what date you see here in Health Connect, this date decides, which data the app can read and how far to the history.

Are your data showing already?

Where’s HR? Lots of info missing

Hmmm :thinking: :cricket::cricket::cricket:

Waited all this time. warm no reply

@lenka-urbandroid where are you?

Hi Visnu, as I explained, we are TWO developers. We need sleep and sometimes rest (like on some weekend days?). We cannot reply 24/7.

I have too little information. How does the graph look like in Sleep? How many SpO2 data points were measured by the wearable?
The HR seems to be synced, there is a red section on the bar. The question mark is a place, where I assume an average should have been. I cannot tell, why S Health is not able to compute an average from the data set of HR points.
The Sleep phases seem to be synced completely.

Health Connect currently does not sync HR, as explained two days ago. I am unsure when they will resolve this because it takes ages to get any reply from them - we have to wait for their reply for two to three weeks, and it is usually only a generic automated reply: someone will reply “soon”.

I will get back to you on Monday. Please, understand, that I cannot work every single day and I also sleep during the nights. I am not an Android, I am a human. So simple reboot won’t do the trick for me, and I need to sleep. Hope you can understand this.

I do understand pardon my “pushing” methods. Health connect doesn’t measure HR ok but what about Samsung Health? Also if Samsung health is syncing with SAA which it looks like because slow and sleep phases are being recorded, why doesn’t it record the HR part too?

Also what is that red line on the graph?

Also you keep telling me there’s 2 of you… Where is the other ghost person? In eternal vacation? Or he needs months of sleep to recharge? :joy::joy::joy:🤷

I mean the whole team consists of two developers, not that there are two humans assigned to support only.
Users would be disappointed and flooded with bugs very soon if the other “ghost person” (who is the main developer) stopped maintaining the app.
Developers may have other tasks to do, and we also have other users.

The red section on our graph is a period, where the wearable did not send any data. Without data, the app cannot plot graph.

S Health should be able to read HR and SpO2 data directly from the wearable.
From the graph it looks like the wearable provided both SpO2 data and HR. Why did S Health not read them is hard to tell… But the wearable apparently had it. Did you allow S Health to read those data?

The Sleep app has both HR and SpO2 - if it was not collected directly from the wearable (without the logs, there is no way to tell), then it was synced to Sleep.
And Sleep did sync the sleep phases to S Health. So I am not sure, what are you asking me to solve for you.

Sleep can only insert Sleep data and Sleep stages.
This screen summarizes the permissions of Sleep. Sleep app can write Sleep and Sleep stages. Which both look synced on the screenshot you uploaded.

Could you please explain which of your data are missing and where?
Sleep has all data, and it synced Sleep Stages to S Health.

Sir I’m not asking you to fix something or reinvent the wheel. Can you just do a small test and see if HR is passing from SAA to S Health. No from the wearable because you don’t have the wellue ring I guess, but from SAA to S Health because it’s not recording HR on my end. That’s what I’m asking

Sleep can write to S Health only Sleep and Sleep phases. So I am still not sure what should I be testing.

Both on on read and write

Ohh SAA can not write HR to S Health. Well that makes sense then. What about the ring? Any idea if S Health can read from it?

Does the native app of the ring support S Health?
If not, you can always use Health Connect as a middle-man. It was meant as a hub, that will collect and redirect all kinds of data. So you can link them, and it should exchange all kinds of data.
Health Connect is still BETA, but most of the time, it works well. Sometimes, there are longer delays between the data sync and the time you will see the data.

See you confused me sir. Health connect can or cannot write HR to S Health? If it can, WHAT can be causing it not to send data to my S Health?

Can you write Data to SAA from another app? I have VitHealth, can it write Data to SAA or not?

Health Connect can write HR data to S Health.
Sleep cannot write HR to Health Connect - temporarily. This will hopefully be solved soon, if we pass the wall of silence and automatic replies from Google support.

Most wearables’ native apps support Google services and Health Connect (or Google Fit), so if the native app can send the data to Health Connect, the HC will sync it to S Health. Just not via the Sleep app.

We do not have support for other services right now. Maintaining online services is time-consuming task (especially because of constantly changing permissions) and we have limited resources at the moment. We had to make our picks, and we can only support the most common ones, the ones, that are usually compatible with the rest (so Health Connect and S Health).
VitHealth is not supported, so no reading data or writing data. But again, you can use Health Connect to get data from most sources and sync it to all other services you are using. So you can link Health Connect and VitHealth.

I’m now clear on all that, but I’m still struggling on why health connect is not sending hr data to S Health. I think I read it needs 7 days to be able to write it. But I might be wrong. If it’s not then what’s blocking it

I must admit, I have never heard of the limit of 7 days before… Anyways, if the data are not transferred from one service to another, the service reading the data usually has troubles. So either S Health can’t read the data (check permissions), or they can read them but won’t save them into your data for some reason. Try S Health support, they should have more insight into what obstacles there might be.