Mi Band - No longer heart rate tracking


#1

For some reason in the last few nights I’ve not had any heart rate tracking from my Mi Band. It’s worked absolutely perfectly for the last year or more so this is all a bit unexpected.

The motion tracking is working as expected.

I wonder if this is related to a recent update to Android that has installed on my Galaxy S9.

I’ve looked at the settings in Mi Band Tools and everything seems as expected. I’ve also checked there and it’s clearly been taking readings throughout the night, they just don’t seem to be making it over to Sleep as Android.


#2

What heart rate reading frequency do you have set in Mi Band Tools? If it’s 5 minutes or higher, data are probably getting lost.

If you had a recent Android upgrade, you might be also missing a Body sensors permission on Sleep as Android. Check it in System settings > Apps > Sleep > Permissions


#3

Thanks for the suggestions. The frequency is exactly 5 minutes, but that hasn’t changed, it’s always been that (I’ll lower it to test though).

I don’t see that particular permission in the list under sleep, so it’s possible my android version isn’t high enough for it yet.


#4

Set to 4 minutes last night. Still no heart rate data.

Movement tracked as normal.


#5

Hello, can you please use menu - report a bug…


#6

Done. I’m going to try re-installing mi band tools and seeing what happens then.