Make the "silent profile" turn off the notification vibrate alerts

From Anonymous on 2015/11/25 21:09:29 +0000

Before Lollipop, Sleep as Android would silence the phone, including all vibration alerts. This was really convenient to just set the alarm and it would silence the phone (including vibration notifications) However, with Lollipop, this feature was removed from the API. I believe that this capability has returned in Marshmallow. Without this feature, setting an alarm requires me to set the alarm, then set the phone to no vibrate. Then when awakened, I need to remember to reset the vibrations to on.

Copied from original feature request:

From Kyli Rouge (Supuhstar) on 2016/03/11 13:03:28 +0000

I have this problem, too, and I'm running Lollipop on my Galaxy S6

From Petr Nálevka on 2015/12/04 13:56:03 +0000

+Annon could you please test the latest BETA version. In fact we are already using MODE_SILENT, but on Lollipop we add VIBRATE too as SILENT does not do silent but instead priority only. In the latest BETA I only enable vibrate on lollipop. Hopefully that helps, but I'm unable to reproduce this issue. On my Nexus 5 Android 6 the silent mode turns on without vibrations when I start tracking…

From Anonymous on 2015/12/01 19:38:37 +0000

In looking at the AudioManager interface, it looks like the 'silent' mode is an option.

int RINGER_MODE_NORMAL Ringer mode that may be audible and may vibrate.
int RINGER_MODE_SILENT Ringer mode that will be silent and will not vibrate.
int RINGER_MODE_VIBRATE Ringer mode that will be silent and will vibrate.

So it looks like if you set the ringer mode to RINGER_MODE_SILENT, it will behave like it use to before Lollipop.