Lucid dreaming - Sleep as Android

Lucid dreaming alarm cues will play once the app detects you are dreaming (in REM phase).


This is a companion discussion topic for the original entry at https://docs.sleep.urbandroid.org//sleep/lucid_dreaming.html

Hi!

This is a cool feature. But I want a vibration on the connected bracelet (mi band 3) to stir me up. Is it possible?

I assume you’ve configured the Mi Band 3 in both the SaA app and in the companion app (I use the Mi Band Tools / Tool & Mi Band app).

If so, these settings in SaA work for me (Mi Band 2):

Settings -> Sleep -> Lucid dreaming ->

  • Enabled [V]
  • Ringtone set to ‘Silent’.
  • Vibrate [V]
  • Volume set to 100%
  • Loop audio 3x

This should give:

  • NO sound from (Silent) Ringtone.
  • Vibration on Mi Band 2.
  • NO vibration on phone.

N.B. The ‘Preview’ vibrates the Mi Band 2 and the phone, but the actual lucid dreaming cue will only
vibrate the Mi Band 2.

I hope this helps.

Hi, this is a great feature.
Is there a way to get this to work in normal (non-tracking) alarm mode? Like, play “you’re dreaming” every 90 mins or a custom interval .
I use the default alarm feature and place my phone far away from my bed (as I tend to switch off/remove my phone’s battery)

Can you please update the documentation on these settings? For example, what does the sensitivity setting do? I am getting sometimes this cue when I am awake. Should I set the sensitivity higher or lower? Since it should only cue me when REM is detected, are there other settings elsewhere in the app to improve sleep phase detection? Thanks. I love the app!

Mine too, the alarm sounds when I am awake!

Hi all,

please have a look here https://sleep.urbandroid.org/how-do-we-measure-your-dreams/… the article describes how we are doing the REM detection and related lucid lucid dreaming and what are the inaccuracies…

Of course there may be false positives as we are assuming your REM phase from indirect hints rather than actually detecting REM - as for this we would need an EEG… To minimize thsi kind of issues you can set the Later setting in Settings > Lucid dreaming and make sure e.g. that the cue does not start in the first 2 hours of your sleep tracking…

J’entends également le signal du rêve lucide en étant éveillée. À chaque fois, c’est quand je me réveille en pleine nuit plus de 2 heures après mon endormissement

MI band 6
My settings:
Settings -> Sleep -> Lucid dreaming ->

  • Enabled [V]
  • Ringtone set to ‘Silent’.
  • Vibrate [V]
  • Volume set to 100%
  • Loop audio 3x

I’m press preview button but no vibration as result. It is normal?