Is sonar safe? - Sleep as Android

Is sleep tracking with sonar safe for your health?

Ultrasound is generally considered safe if it is at normal volume. Regarding health effects, it works in a similar way to normal audible sound, i.e. very loud ultrasound can damage your hearing, whereas at low volume it is safe to hear. When using speakers, smartphones are nowhere close to be able to produce such loud sounds as to damage your hearing. We also use ultrasound that is very close to the hearing range (around 20 kHz), so the effects of the ultrasound are almost identical to hearing a high pitched sound at the same volume (expect you can’t hear it at all). The ultrasound volume we use is around 40 dB – which is lower than normal speech volume. You can measure the sound level yourself using e.g. this app.


This is a companion discussion topic for the original entry at https://docs.sleep.urbandroid.org//faqs/sonar_safety.html

Can sonar be used with headphones so one can hear binaural lullabies or is this not safe for hearing?

If sonar ONLY emanates from speakers on Android I would not expect this to be a problem. However, if sonar goes thru headphones as well this would magnify the ultrasound focused into the ears.

If headphones are plugged in to Android then sonar should not be routed though headphones or sonar should be prevented from working.

Hello, please definitely do not use Sonar with headphones… there is a warning about that on the tracking screen if you use Sonar and headphones would be plugged in…

We cannot decide to play ultrasound though speaker only, this isn’t possible on Android, we need to use the media stream so all ultrasound is routed to the headphones…and sonar won’t work and you will get unnecessary ultrasonic signal into your ears

1 Like

What is DND?
Check NO where per message?

I inserted earbuds briefly to find this note. (NOT INTO EAR but just briefly to find this message in the app) Note should be highlighted in red to with WARNING written.

Also, in attached screenshot what is the bluetooth icon with the sonar ?? at bottom of my screenshot? How do I get rid of it? Using a Samsung A5.

Hello, the whole message reads “Sonar won’t work: ensure maximum media volume, disable DND ALL, unplug headphones or check no other app is using the mic”

DND is do not disturb mode…

The BT icon is there because you enabled wither Settings > Wearable > HR over BT Smart or Oximeter at the smae place…

Why is the FULL message not appearing per my screenshot?

Does not give a warning about any possible hearing hazard, which it should. It just says sonar MAY not work. Perhaps this message and Documentation needs to be clarafied.

I disabled the bluetooth so no more issue as it somehow got turned on, probably by per your answer below.

Still learning about this app and trying to closely read the documentation as I just installed it recently and am still within the 14 day trial.

Thanks for the prompt response. Now trying the accelerometer and other functions

Hello, I don’t think there would be any hearing hazard… it depends on the dynamic response curve of your headphones but after 18kHz the output gets steeply down, so the output of the ultrasonic signal should be equal or in fact much lower than the sound from the hearable spectrum… also when we detect that headphones are plugged in we will stop producing ultrasound…

A bit of a relief. In trying out SaA I started with sonar after trying a couple other apps with accelerometer.

Then tried lullaby music from speaker with sonar which seemed ok but need to adjust freq/vol to avoid hearing “chirps” etc.

Read about using binaural beats and wanted to try that but obviously not a good idea with sonar and earbuds/headphones. (even if the sonar worked)

I tried using this with earbuds in ears with sonar then starting the sleep program. So LOUD I pulled the earbuds out within seconds. Hopefully sonar was not working then per your above note.
.
If sonar was working I may have heard high audible sound generated from sonar hitting the inside channel of the headphone port as it exited with a strong force. Alternatively, I may have somehow moved the volume up way high.

This raises the concern that there should be a way to lock the volume level someplace so it does not accidentally get changed to a very high and dangerous level. A feature to be looked into.

Thanks again for addressing this issue.