IFTTT "smart_period" not working


#1

Hi. I set up IFTTT to trigger a Stringify action when Sleep’s smart_period command was sent. It worked once but it’s not working anymore. I checked the IFTTT Activity and errors, and it didn’t run there.
I also set triggers for “sleep_tracking_started” and “alarm_alert_dismiss” but these work fine, they appear on IFTTT’s activity.

I understand the “smart_period” is triggered 45 minutes before the period starts, so the alarm needs to have a smart period enabled for this to work, and the sleep time has to cover the total smart period time plus the 45 minutes, so I’m not taking in account the nights that these conditions weren’t met. I sometimes disable smart period depending on the day.

Any idea of what could be happening?
Thanks,
Rodrigo


#2

Hello, can you please use menu - report a bug? I will check the log…


#3

It worked today, but it showed this error on IFTTT Activity. The time of the error (6:32) is weird because the alarm was set at 9 with 40 min smart period. Then it was triggered correctly at the right time (7:35).

This is the log, it didn’t work on monday, it should have ran at 8:35 and this applet doesn’t appear on the activity at all on monday.
https://drive.google.com/file/d/1B65Xf0b2aSujA5XCzdEP9_n-KJJflWWD/view?usp=sharing

Thanks!