IFTTT - Sleep as Android

sleep_tracking_started …​ sleep_tracking_stopped …​ sleep_tracking_paused …​ sleep_tracking_resumed …​ alarm_snooze_clicked …​ time_to_bed_alarm_alert Fires when you get a bedtime notification alarm_alert_start …​ alarm_alert_dismiss Fires when you dismiss alarm (after you solve CAPTCHA, if it’s set) rem Fires when we estimate the start of REM phase antisnoring Fires when we detect snoring smart_period Fires 45 minutes before the smart wakeup period starts

This is a companion discussion topic for the original entry at https://docs.sleep.urbandroid.org//services/ifttt.html
1 Like

Hi, my sleep as android doesnt seem to successfully connect to IFTTT despite successful log in with email

Hi there. I try connecting but the page to connect the webhooks (after log in) keeps refreshing and I can’t do anything on it… any ideas?

I had the same problem. To get it working you first have to go to IFTT and connect Webhooks. I created the applet first, then went back to SleepasAndroid and it connected. Should be added to instructions.

Hey, I do wanna start a sleep tracking with Google Assistant and end up here. Seems like there’s no such an option even with IFTTT, is this true?

1 Like

I couldn’t get the IFTTT trigger working and I don’t believe it’s mentioned in the docs, but in IFTTT you have two options: Receive a web request and Receive a web request with a JSON payload. They have 2 different endpoints. Intuitively I was selecting Receive a web request and it was not working because Sleep as Android is sending the trigger to /json/with/key instead of /with/key…it would be great to add that in the documentation. Also in the app the events are in uppercase so I was trying to enter the desired event in IFTTT in caps but in the documentation is lowercase. Might be good to update the app and let users select lowercase if that’s the case for all services (I only used IFTTT)
Hope this helped

Summary

This text will be hidden