How do I get the app to actually sync/connect to my versa lite

So when I first click wearables and then choose the Fitbit and then choose test sensor It says it’s trying to connect to the Fitbit and when it gets almost all the way there then I see an accelerometer but I don’t know what that is or how it works. However when I did go to sleep the other night it never could connect to the Fitbit.

I’m wondering if there’s something I need to do on my Fitbit watch or the Fitbit app to help the sleep app connect to the Fitbit.

Thanks for any help in advance

Hi, the test sensor feature does not work with Fitbit as it is not possible for us to start the watch app by a command from the phone.

The correct procedure is this:

  1. Force stop the Fitbit app on your phone and restart it again. This is an optional step, but sometimes the Fitbit app will break connection between Sleep as Android and the Sleep app on the watch. Restarting the Fitbit app helps.
  2. Make sure that Fitbit is selected in Sleep as Android > Wearables > Use wearables
  3. Start the Sleep app on your watch.
  4. Start sleep tracking in Sleep as Android on your phone.
  5. In a few moments, they should connect and your watch should show that it’s tracking.

I have tried absolutely everything. I did everything in your reply above, I then also tried the following: I forced shut down the Fitbit app. I cleared the cash of the Fitbit app. I rebooted the watch. I tried starting the Fitbit app first making sure it’s synced, started a new go to sleep mode with the app and then launching your app and And tell it I’m going to sleep and then it tries to connect to the watch unsuccessfully.

I akso tried launching your app first and when it starts looking for the watch then started the app, and made sure it synced with the watch.

It’s simply does not work. when I finally get up in the morning there’s notifications on my phone that your app is still trying to connect/waiting for the watch but no battery is being consumed.

Not sure what else I can do to try to make this work.