Heartrate and SpO2 not working in BETA [Fossil Gen6]

Hi everyone,
first time posting here, so sorry if another thread already exists.

I recently bought the new Fossil Gen 6, which has an SpO2 sensor.
I tried the stable version of SaA, but only managed to get my heart rate tracked.

I went to the support, which recommended I try out the beta version of Sleep as Android.

In the beta version, neither my heart rate nor my SpO2 get tracked.
I went into settings on my android phone, tried to re-enable heartrate tracking and had the following issue:

The problem is, when I click on “SETTINGS”, there is no option on my android phone to allow these permissions.

Any idea how to solve this?

Thanks

1 Like

Hi @spqx,
Welcome to the forums!
If you visit the Sleep as Android app in your list of apps in settings, and check the app’s permissions list does it include anything about sensors?

Hi @Fufu_508,

in the app settings of SaA, there is nothing about sensors in any way, neither in “allowed”, nor in “denied”, see this screenshot:

Hi @spqx Interesting. My Samsung Galaxy S8 running Android 9 does show sensors.

I’m getting this message as well but only with hearrate tracking after switching from the Pixel 4 to the Pixel 6!

Screenshot_20211129-145158|225x500

Heart Rate tracking permission is included in “Physical Activity” settings on some phones. Body sensors on other phones.

There is a current issue with heart rate tracking that may be fixed in an upcoming fix, according to support.

Fixed with Version 20211129 (22562) for me