Google Calendar integration not working for me

I’ve been trying to upload my sleep data to Google Calendar but Sleep says “no calendar named Sleep or with the tag #sleep found”

I made a calendar named Sleep and still got the error. Changed the title to #sleep got the error again. I’m not sure if I’ve done something wrong or if there’s something I’ve missed. I’d really like to get the calendar integration working.

I had the same problem, after creating the calendar named Sleep I synced everything, I even turned off the phone and started it again, but it didn’t help. But when I checked an hour later it worked.

Nice. It worked for me just now. Thanks.

I’m also experiencing this issue, but neither restarting nor waiting resolve it for me; was there anything else you had to do?


@edobry Just wanted to add my experience to this thread. I too waited and waited. It took 2 days but it worked. I created a calendar called “Sleep #sleep”, and after 2 days it finally was recognized by the app. Hope this helps.

I am experiencing the same issue for about half a year. Unfortunately, for me, nothing fixed the problem yet.
I tried to change the calendar’s name to different variations of “Sleep”, “#sleep”, “Sleep #sleep”, and I’ve waited for hours and days, but nothing helped. I even switched phones during that period, but the problem persisted in the new phone.
What else can I do?

Hello, at the moment we know about 2 problems with the Calendar… if you later on revoke the permission for Sleep as Android to access the Calendar we were not able to recover that… this is fixed in the latest BETA version (if you want to give it a try please let me know and I will send you instruction on how to get the BETA)…

Also we have notices that for some users we are getting response from Google Calendar - service disabled… at the moment we do not know what is causing the later issue…

I had the same problem in the stable version, relinking my Google calendar account seemed to work

Thanks, can you elaborate on how have you relinked the Google Calendar account?

Yes I would be happy to try the BETTA, can you send me the instructions for getting it?

Sorry for the late reply. I just went to settings, services, unticked the Google calendar option then ticked it again. About a minute later, two sessions which didn’t previously show up on calendar, appeared normally.

Also sorry fro the late reply @barak here is how to get the BETA…

Please first join our BETA Testers group at:!forum/sleep-as-an-droid
That you can opt-into the BETA at the following address:
Or simply by visiting our Play Store listing and tapping “Join BETA”

After that you should be starting receiving latest BETA updates through the Play Store.

So I’ve tried all different combinations of both the standard and the beta, and a variety of calendar names from above. In all cases, I try to check the Google Calendar option, it displays the account selector dialog, I pick the account and the checkbox un-checks immediately - is this what other people see?

Cloud backup and Google Fit both are sync’d successfully.

Just wondering if it might be worth adding a text box to the checkbox for Google Calander option that people could paste their CalendarID into?