Gear S2 Companion .wgt / .tpk file (How to install Sleep on Gear Fit 2)

Could someone please provide me with the .wgt file for the Gear S2/S3 Companion? I have the Gear Fit 2 Pro and want to attempt to re-sign the .wgt for the S2/S3 and see if it will work with my Fit. I have the certificates created for my device I am just lacking the .wgt file which I cannot find anywhere.

Hi Chris, the Gear app does not compile to .wgt as it’s not a web app but rather a native Tizen app bundled with a native service.
I’m attaching the latest .tpk, but I’m not sure whether it’s possible to unpack and re-sign it. Fingers crossed - let me know if you get lucky!

sleep107arm.tpk (157.8 KB)

Thank you! I will report back.

Yes it worked! At least it installed and the sensors seem to be working. I will see how it does tonight.

Here’s a big :fu::fu::fu::fu::fu::fu: to Samsung!!!

Wow. I didn’t believe it too much to be honest :slight_smile: Would you be so kind to put up some brief steps so that other people could do the same?

Tried it out last night and everything seemed to function fine, used about 35~40% battery but I sort of expected that. I either had a bad night or the watch is too sensitive to movement because the graph looks way different compared to sonar. I will start a thread in Q&A regarding that issue though.

Here is the link to the steps I followed:

The one thing I struggled with was getting the certificate manager installed under Tizen studio. You have to install the one under Extension SDK and then there is another one under Main SDK>Tizen SDK tools>Baseline SDK. The instructions just mention the one under Extension SDK.

Creating the certificate is the most complicated part, after you have that the rest is super easy. Just drop files in a couple of folders and run a few .bat files and its done.

The newest version of the Sleep app for Gear is here…
sleep109arm.tpk (181.5 KB)

(sorry for edit, there was a hot bug in the previous upload).


  • fixed issue with sensor data format being dependent on locale (caused troubles where comma was used as a decimal point separator - mostly EU countries)
  • fixed version number mismatches