Garmin - Cannot accept start dialog (green tick) - Sleep as Android

This dialog is the only way to start a watch app from the phone. There’s unfortunately no way to do it without that dialog.


This is a companion discussion topic for the original entry at https://docs.sleep.urbandroid.org//faqs/garmin_start_dialog_bug.html
1 Like

Starting sleep tracking from the watch is not starting sleep as Android app on the phone.

1 Like

I am having the same problem. I emailed the developer and was told the only way to start the app was through my watch. They didn’t even try to address the issue. I’m so frustrated!

Hello, as we explain in support emails, this bug has been reported to Garmin and we are waiting for a patch to be released. This is not something that can be fixed on our end.
This issue should appear only on VivoActive watches, where the confirmation dialogue is broken, and the tracking can unfortunately start only after this dialogue is confirmed.
We are sorry for this, hope Garmin is working on a fix.

This approach, of starting app on the watch, worked until the middle of October. It no longer works.
It ties in when an upgrade from you changed the color of the comments on the watch changed from white to brown.
How can we get the prior version . The version that worked

The work around doesn’t work at all now. I start Sleep as Android on my watch and it never connects to the phone, it just freezes the app on my watch. There is no communication and the only way I’ve found to stop the app at that point is to restart the Garmin.

2 Likes

Any solution yet? I’m in The same boat.

Hi, I have a new Garmin fenix 6 pro solar. On my old Android Wear smartwatch Sleep as Android worked fine. On the Garmin I have the problem that the watch freezes when starting sleep tracking from the phone (as mentined here). When starting from the watch, the watch freezes as well but shows sleep tracking data on the phone the next morning. Unfortunately the alarm on the watch doesn’t work at all. Will there be a new version of the garmin app that works on my fenix 6 pro?