Forbid vibrations on phone when using wearable vibrations for anti-snore alarm

Disable vibrations on phone completely, so only a wearable vibrates for anti-snoring. Even when the connection with a wearable is lost, do not allow vibrations on phone (some phones have very laud vibrations disturbing others).
support email with Andrea

I’m glad I’m not the first to have thought of this. I like the concept of anti-snoring: my smartwatch can vibrate a little to prod me out of snoring. But if the phone on my bedside table starts rumbling, my wife won’t be happy!

1 Like

Hello, this issue should be already fixed - and only one device is used for anti-snore vibration (either a phone, or a wearable when used for tracking).
In “Preview”, both devices vibrate to test it, but in a real-life situation, only one of them should vibrate.
Does it mean, this is not working for you?
Could you please contact us directly at, or even better - use Left ☰ menu > Report a bug, after you reproduce the issue, or in the morning after tracking? Thank you.

Thanks for clarifying. I’ll give it a go.

I tested with Preview and both devices buzzed, so I logically assumed that’s how it’s going to work. I suggest that you make that more clear in the app.

I have a Samsung S9+ and an HONOR Band 5-850, I think the band works for tracking, in automatic mode. It takes a while when I click ‘test’ in wearables, to show a graph, but does eventually. However, it does not vibrate when I click ‘test’ within the anti-snore section, only the phone vibrates. Am I doing something wrong? Or is this device not yet supported fully?

Hello, the Honor Bands are not supported, so the anti-snoring vibrations won’t work on them.
We have integration with all their Wear OS-powered watches, but RTOS does not provide the required integration options. The device needs to have an API that grants access to adhoc sensor data.
​And unless HuaWei shares the API, there is not much we could do. I am very sorry.