Fitbit Ionic/Versa beta integration


#61

worked fine yesterday, the app was still on in the watch this morning.
My cell restarted around 3 am so I got an incomplete night but looks fine anyways.
Lets see tonight.
Heart rate is still coming from Google Fit.

Note: following the process I wrote in the previous reply I got the tracking working the first try.


#62

I used the @ludohavil method to start the sleep and it worked first time! But go a weird graph. Lets see what happens tonight.

image


#63

Oddly enough, I am unable to get my versa to connect to the server on the latest 0.8 version, regardless of how I try. This includes using the method mentioned above of starting the server, syncing with Fitbit, and then starting the app on the watch. Or just says it’s connecting. Have submitted a bug report. Too bad about the JavaScript problem, and I hope it’s not too hard to get sorted out!


#64

Version 0.9 available!

I’m still figuring out what goes wrong and why the app stops. Currently I’m at the point where, after a totally random time, either the watch app or the phone companion (the javascript I was talking about earlier) just stop without throwing any error. Which one of those stops is also totally random.

However, me and some of you have gotten the best results so far with version 0.8, so I wanted to ask you for further testing with checking some options that are external to our app. The new version 0.9 has only a very slight alteration that tries to keep the companion alive (@treyhendon it’s not the second app yet) .

For further tests:

  1. Pair the watch to your phone via Android’s bluetooth menu
  2. Enable All-day sync in the Fitbit app
  3. Enable Always connected in the Fitbit app

Thank you!


#65

Yesterday morning and today mine was OK, the day before the cell restarted and kept waiting for the SIM security code so I got a partial graph that night, but the last two days has worked fine.
Installing 0.9 and testing tonight.
Thanks.

Note: @jiri-urbandroid - I do have it configured the way you just recommended since I started using the Ionic.


#66

With 0.8 tracking worked fine for me. With 0.9 the old behavior of stopping after 40 min came back. I have sent in the bug report this morning. What I did not know at that time was that something in the Fitbit app has apparently crashed as even after restarting the watch I still wasn’t able to sync anything in the Fitbit app. Only after restarting the phone the Fitbit app behaved as usual. ( Oh and I had already set the Fitbit options as described in your post)


#67

It should suffice to force close the Fitbit app and start it again.


#68

I had actually tried that and it did not help. Also disabling and re-enabling Bluetooth did not help. So it seemed like more than just the Fitbit app crashed. I’ll keep an eye on that maybe it was just a one time issue.


#69

I must be in the few, but watch app v.8 never worked for me, v.7 was the past one that worked best for my Versa/Pixel.

That said, v.9 worked great last night! I even had to get up in the middle of the night to check on my daughter (too far for Bluetooth to stay connected) and that activity was properly recorded (and never showed red for disconnected in the graph).

No heart rate in the graph this morning, but not sure if that’s back in scope yet or not (with the previous crash issues).

Thanks Jiri!

Versa App: .9
Phone App: 20190415


#70

Yep I haven’t added that yet.


#71

V 0.9 worked fine last night, in fact I have not had any issues since before V 0.7 (IONIC / Moto Z2 Force here).
@treyhendon the heart rate some time we write about is coming from Fitbit app to Google Fit through FitToFit, and Sleep is getting it from Google Fit, but I don’t think Sleep is using it to do the sleep calculations, but its good to see it there for reference at least.


#72

Hi, I’m new here. I replaced my Pebble time steel with a FitBit Versa lite, and I was very excited when I found this thread. Unfortunately, after switching to beta with SAA, I still not able to connect it to my watch. Most probably, because I could not install the helper app to my watch, it tells me it’s not allowed. I do not know what is the exact difference between the Versa and the Versa lite, but I hope this is only a configuration issue related to the app and I will be able to use it.


#73

Welcome @Mochrul and thanks for joining us! I didn’t release the app for Versa Lite so that’s the reason. I’m afraid I won’t be able to do that until Saturday but it should be just a formality on my end then. Thanks for the notice!


#74

Everything has been great until last night the app on the versa just would not start the app on the phone. tried all the standard things but gave up and just used the phone lets see what happens tonight.


#75

Still working fine for me.
One question, in the bottom of the graph there isbthe icon of the watch, but yesterday and today I got a grey circle besides it. What means the grey circle?
I have also the circle before but just the border, not filled like today.
Note: I realized what it is: the moon fase.


#76

Thank you @jiri-urbandroid and no worries. But please alert me when it’s ready so I can check it.


#77

Moto G5S plus/versa.
0.8 watch app stay open all night, but tracking data not recorded on phone app for whole night. Seems like no specific timing on tracking stop.
Now 0.9 watch app won’t stay open all night. First night was 30 mins or so, last night it appears to be under 5 minutes before it closed. I have sent logs.


#78

Hi! Long time sleep as android user, first time installing Fitbit app and tracking last night, worked very well! I’ve sent you a debug report just incase there’s useful info there.

I’m actually a web dev so thought I might offer my assistance in helping improve the Fitbit app if you need? I’ve got a thought or two on simple ease of use of the Fitbit app. Feel free to reply to my bug report, or the email I used there, to discuss further. Thanks!


#79

@Joel_Balmer (replied in an email)


#80

Version 0.10: https://gallery.fitbit.com/details/90650cd6-76fa-40db-a747-240ac7da8a02

I found out (was told by a Fitbit employee) that there is currently a bug in Fitbit. When you launch any app/watchface for the first time after install or update, the companion (the part that runs on the phone) will not work reliably.
This is a crucial part for Sleep as Android, so please, after installation/update, start the app on watch and exit it. After that, this issue should be gone.

Hope you had nice Easter time!