Fitbit Ionic/Versa beta integration


#41

I sent a bug report in as well. Noticed something similar. There was definitely days in the graph on the sleep screen but it went away as soon as I did the close and save thing. I also noticed that the app want running when I woke up, so I’m not sure how there was data. A bit strange. Anywho, thanks for continuing to work this out!


#42

Same thing happened next night. The app was running on the watch when I woke up but no graph. I send the bug report. I will try again tonight. Let me know if you still want reports each morning. Thanks for the work!


#43

Hi,

my first post.
just got my Ionic and started testing last night.
same thing as djjstew showed in the screenshot, no data at all, only sound in Sleep.
also the app in the watch was not running when I woke up.

I’m testing Ionic with latest firmware, latest Sleep beta and 0.5 fitbit app.

Thanks for this development, purchased the Ionic when I found this.


#44

second night.
today the heart rate worked all night but the sleep tracking was at a constant height with the light sleep color. The sleep tracking in the Fitbit app worked fine.
sent the bug report.
hope it helps.
one question: how do I know if the app is still running? this morning the heart rate was tracked but the app was not running in the watch for what I can see.


#45

I have been trying on fit bit versa. The watch app is closing almost instantly after it connects to my phones app and starts the sleep tracking. I have 15 minute wait period before tracking starts normality, so I disabled that and the app didn’t crash. Even so there was was no tracking or heart rate data come morning. I have sent bug report.


#46

Hello and again, big thanks to everyone who’s sending me logs.
I’m not able to answer to every email with a debug log so please don’t expect that, but they’re very helpful.

I’ve got a new version that I’m not entirely sure will work perfectly but it is another step closer. Unfortunately the Fitbit servers are down currently so I can’t publish it right now but will do as soon as I get a chance.

Changes:

  • I’ve switched the bluetooth communication to use the Messaging API instead of the File-transfer API.
  • I’ve turned off heart rate monitoring completely as this seems to be causing crashes for yet unknown reasons (maybe a native crash?)

#47

If you see it on the watch, it’s running, otherwise it’s not. Fitbit has no multitasking.


#48

thank you for the clarification.
then it was closed cause the clock was what I saw when I wake. curiously the heart rate was logged in Sleep app until 7:53 so the app closed at that time.
I will install the new version as soon as available to test tonight.


#49

The updated version is public, hope to see some less crashing!


#50

Happy to report that I tested this afternoon while working and got several hours of good tracking. Until near the end when the watch disconnected and then reconnected.

Here’s a screenshot and I’ll also submit a bug report for debug.

One last thing - I mentioned before, but it really would be great if the server would auto start when tracking is started on the phone. After phone rebooting, the server was not running and it’s cumbersome to get to the “start server” command. An alternate idea - a sleep widget option that would start the server. So I could add that to home screen. Really, it’s all about launching the server on the phone easier so I can then start the app on my watch.

Thanks for all the great work Jiri!


#51

Hi guys,

When I click the links to get the Fitbit app I am taken to the Fitbit gallery, but it says ‘No internet connection’, however I have connection and I can install other fitbit apps. I tried also to find the app manually on the fitbit gallery, but there is no such app. Can you help me out?

Thanks.


#52

the app worked all night, I got a nice graphic yesterday.

as you can see the heart rate is there, since it should not be from the app, I think it could be coming from Fitbit app thorough Fittofit to Google Fit and from there to Sleep?, I have Sleep connected to Google Fit.

Note: I’ve noticed the battery use doubled when the Sleep app is on in the Ionic. between 9 and 10 % when app on, 4 or 5 % when app not in use.


#53

Worked fine for two nights. Had trouble starting the process, fist night took 3 tries and last night took about 6 tries. Last night it worked after I stopped the server and restarted. After that all went well so lets see what happens tonight. I sent in the report.


#54

worked fine again. I can see the heart rate again too.
took me like 4 tries and worked after I restarted the service in the phone like djjstew wrote.

editing because I cannot add more replies.

Monday April 8:
another night that worked fine.
after a few tries to start I went to the Fitbit app and after the watch sync went back to Sleep and then was able to start tracking fine. So if anyone have trouble starting the tracking, try first to sync Fitbit app with watch.
One thing I noticed, the sleep tracking in Fitbit app is all messed the three days Sleep has worked fine.


#55

Three Night report on the App:

Sunday and Monday App started first time and was running when I woke up and the graph seemed normal.

Tuesday night could not get the app to start and I tried many times and just about everything I could think of. I gave up and went to sleep.

@ludohavil the heart rate is coming from Fittofit since I was not aware of that app until you posted. I installed and since then the heart rate is on my graph and must be coming from Gooogle Fit. Nice, thank you for that!


#56

@djjstew Your welcome, glad I can give something in return.
You can notice the heart rate is not full if you check just when waking up, it will be full the next time Fittofit sync with Google Fit. No idea if it will be used by Sleep, coming for Google Fit, to get a better sleep reading.
@jiri-urbandroid Any update in the near future? You have being very quiet for the last days.


#57

Big thanks for all reports!
Sorry for not being more active here, we’ve been doing a thorough review of the code, especially the messaging parts, and have some improvements there.
Apologies again - the integrations takes a lot more time than what I initially thought and I have to simultaneously catch up on other parts of my workload that have been a little neglected…:slight_smile:
But getting this to work is still the highest priority for me.
I’ll release a new version of the app tomorrow as today I had a day off.


#58

Guys, I’ve released version 0.8. LINK
I’m however not much optimistic on this since I ran into an issue which I’m not able to overcome and that is that the phone part, which is some javascript running inside of the Android Fitbit app, just randomly stops, at different times, and it seems that something inside their Android app is crashing. I’ve reproduced this many times now and I’m not really sure that we can work around this reliably on our end.
I’ve reported this to the Fitbit team and hope to get some answers.

Please try the new version as we’ve made a lot of improvements there but this seems to be a show stopper at least today :slight_smile: Let me know how far you will get, and I’ll also keep you posted of my progress.

Big thanks to everyone!


#59

Downloaded and gave it a try at work. Had to restart the server after 3 attempts failed. Lets see how this goes tonight! Thanks Jiri


#60

remember to star the server, sync with Fitbit app and then start the tracking in the watch.
this has worked for me so far.