Event smart_period does not fire with automations

Detailed description of the problem:

In automations (tasker and mqtt) the event: smart_period does not fire.

Steps to reproduce:

Set smart period to 5min.
Enable automations and all events.
Set alarm 1 hour from now. (this should mean that the event smart_period should fire in 10minutes)

Version of Sleep as Android:
20210312 (22292) premium
Samsung s10 OneUI 3.1
Android 11

1 Like

I’m also having this issue. The other Tasker events, like the start of the alarm, work fine.

Thanks.

Same for me. Broke when I updated and can’t downgrade without losing all app data.

Hello folks, sorry for the issues. We have kind of fixed the smart period even in the previous release so it triggers exatcly at the smart period start - not 45 minutes earlier… but we see more reports now that you have already hooked your routines to that event and you are using it in the way it was… so we are in fact introducing the Before smart period event, whcih will work exactly as the old smart period event, please do not forget to enable that event in Settings > Automation > Events… sorry for the issues…

1 Like