Disabling vibration for MiBand 2 does not work

Detailed description of the problem:
I tried disabling vibration for wearable devices, but the MiBand 2 still vibrates in the morning.

Steps to reproduce:
Set an alarm
Disable vibration for wearables

Version of Sleep as Android:

20180316

1 Like

Also having this issue. Mi Band 3, using Notify & Fitness.

Although it doesn’t solve it, setting the vibration time to the max, 24 minutes, still works. So that way it at least doesn’t vibrate until a long while after the alarm.

When using this method, though, I found that, while sleep tracking, if you dismiss an alarm and set a new one, then return to the sleep tracking screen, the band will vibrate immediately, no matter what.

Version: 20190109

So there’s actually a better workaround that seems like the expected behavior for Notify and Fitness’ integration.

Under the hamburger menu, turn Simple Mode off.
Go to the charts/graphs section and, under “Sleep,” there should be a “More Options” area.
After pressing that, there’s a Sleep as Android section where you can turn off all vibrations for the app, outright.
Did not see this on my first go around, but hopefully it helps with anyone that needs this and has the app.

Edit: Wanted to clarify, the above steps are using the Notify and Fitness app.