Can't start sleep from Pebble Classic any more

Detailed description of the problem:

Starting sleep from my Pebble classic watch no longer works, as of sometime in the last few weeks. Launching the app on the watch displays the current time, with moon and pause symbols like it always used to, but the time of the alarm never appears below the moon, and sleep tracking never starts on my phone.

Steps to reproduce:

Launch the sleep app on my Pebble classic watch.

Version of Sleep as Android:

Currently on version 20181214. I’m pretty sure it happened with 20181212 also.

Same here with Pebble 2 HR. I’m unable to start tracking from the watch.

If I start tracking in the app though, it’s reflected on the watch and the alarm time is shown.

I’m on the latest stable version 20181212 U2.

The bug was present in the beta version as early as November 23. Despite submitting feedback about it on the Play Store beta feedback section, this bug has been carried over to the stable version which is disappointing. Why have a beta testing program if you’re not investigating reported bugs?

1 Like

For anyone experiencing the issue, you need to install an add-on from the Play Store.

the issue is we had to upgrade the app to target latest API levels otherwise we would not be able to publish our app on the Play Store - this is Google latest policy.

Targeting latest API levels breaks a way we could get messages from Pebble. This is why we prepared for that in advanced and released a special app on the Play Store which translates Pebble messages so that they can be received by new apps with new API level targets. This app does not target latest API level so that it can work that way and it can stay on the Play Store although we will never be able to update it :)…

So to resolve your issue please just download the following app and starting from watch will work again for you:


Thanks a lot for the info! I’ll try that tonight!

Was struggling with this on my Pebble Steel Time…Could get the app to work with test sensor, but not actually fire up the app or get sleep data. Thought it may be something with pebble so even tried switching to rebble (which gives pebble app store) but no joy.
Downloaded the link above and back up and sleeping :wink:

Same here - worked for me!

The add-on worked perfectly for my Pebble Time for a while. But now I have to touch the phone to start sleep. Perhaps I need to uninstall and reinstall the add-on. It’s no big deal: just a few inches movement of my hand. But it’s a nice little perk.

Oh, Rebble works identically to Pebble OS in this regard. In almost every way, actually.

I fixed it by refreshing the add-on. I can now start from the watch again.