Can not connect my Samsung Active 2 to SAA

First of all, I am sorry if this is the wrong place to post this, but I am really desperate at this point and I could not find anything direcly related to my problem online. If there is some kind of help-section in this forum, I did not find it :confused:

Detailed description of the problem:
I want to use my Samsung Watch Active 2 for Sleep tracking. However, I can not get the integration to work.

I already installed the Sleep as Android Gear Addon (Which is not really necessary from my current understanding. And this addon is only required for the older samsung watches. Would be glad if someone could verify this or tell my that I am wrong.)
I also installed the Sleep as Android Native Gear Companion on the watch.

What I can do is start sleep tracking from the SAA Native Gear companion on my watch, but SAA does not actually receive any data from the watch. At least in settings -> wearables -> Test Sensor the watch does not seem to connect.

Steps to reproduce:
Go to settings -> wearables -> Use wearables -> Tap “Samsung Gear / Galaxy Watch” (the new one, see the attached picture)

This opens the app store to the Galaxy Wearables app. Which shows the following error:

Your device isn’t compatible with this version.

Which is strange, because of two reasons: I am using a relatively recent phone (OnePlus Nord) and I already have the wearables app installed :dizzy_face:.

What I found out is that there seem to be two different Samsung Wearable Apps. The link to the Galaxy wearable app that is working for me is https://play.google.com/store/apps/details?id=com.samsung.android.app.watchmanager

While the Version that is linked from within the SAA App is https://play.google.com/store/apps/details?id=com.samsung.android.app.watchmanager2

(Note the 2 at the end of the second link)

I am aware that this might not be a bug within SAA, but I would reeaally love some clarification on this issue. Why are there two Samsung Wearable apps? Does SAA support only one of them? Do I need to wait for my phone to support the new samsung wearables app? Is this a known issue? Was there once support for the old app Wearables app, but not anymore? Are there maybe any workarounds for this problem?

Anyways, I hope I have provided enough information, and am greatly looking forward to any responses on this topic :slight_smile:.

Version of Sleep as Android:
According to the “Release Notes” page within the App, I am using Version 20210808 (22471)

Hi!

Please note two things:

  1. Sleep as Android Gear Addon IS needed - it’s a crucial piece in the chain. The message flow is Sleep > Gear Addon > Samsung Wearable app > Watch app (and back).
  2. Please use the old Galaxy Wearable option. The new Galaxy Wearable app is only being used by a very small number of Samsung phones - we do not know what exactly is the difference between those two apps but as the other is incompatible with your phone, it’s apparent that you need to use the “old” one.
1 Like

Ah I see. Lots of thanks to you for this clarification :slight_smile:

Hi, I tried it again and for some reason it worked this time. Using the “old” Galaxy Wearable option in SAA fixed the issue for me. I think it is a bit confusing that the tooltip in the SAA App just says that there is a “new” and an “old” Version. I assumed I need the new version, since my watch is somewhat recent.
Anyways, that’s just my two cents. I am sorry for the noise I caused.

Great that it worked for you and no trouble! We’re actually consolidating those two options into one for the next version to avoid exactly this kind of problem.

1 Like