[BUG] BackupFeature [Solved]

Current SaA App-Version: 20201010
Mi Fit-App: 4.8.0/ Mi Band Tools: 5.1.0
Device: Samsung Galaxy S8+
Android-Version: 9.0
Record-Type: Smartwatch Bluetooth
Smartwatch: Mi Band 2 (BT-connected) / Firmware-Version: V1.0.1.81

Hello there,

former beta test, now stable user.
Now to the bug.

I accidentally deleted my sleep-records.
I tried to recover it from my localdata, my dropbox and sleep-cloud account.
There i noticed the last log was from 29.9.

Luckly i paired it recently with google fit. There it does the logs exist untill today (14.12.2020)
I tried to resync it back to SaA. That fails!
Google Fit shows me the data, but the Apps show me a running backup, but doesn’t show me the recent data.

Now i was worried and looked up the local app data.
There i found sleep-export.csv (16MB) and sleep-export.backup.csv (0MB!).

I imported the former one and got my logs back.
Btw. localbackup was disabled and i tried to restore the backup before i noticed the csv.
Still it contained my recent data.
Now my second question ìs: Does the csv countains all the sleep log or is that copped at one point?

lg
KlonAmy

P.S.: I assume the restore function checks the date and fills only the the missing data?
P.P.S.: Is there a way on the sleep-cloud to view the very first data?

Note: Uploaded or updated my backups.

I have also problems with the Sleep Cloud. I log in before I upload the data, first from all clouds. Then I log back in and the thing works. Does anyone know a different solution?

Hello guys, sorry for delay in looking into this issue.

We have released some fixes in SleepCloud in the mean time, can you please let me know if this is still an issue. Provide some detailed steps what is happening and ideally use menu > report a bug from the SleepCloud app and send us the report?

Bug thanks and sorry for the issues…